Performance issues with CentOS and VPC 2007

If it doesn't fit in another category, ask it here.
Post Reply
MrDHB
Posts: 1
Joined: 2008/03/16 15:32:12
Location: UK

Performance issues with CentOS and VPC 2007

Post by MrDHB » 2008/03/16 16:30:31

Hi, I'm a CentOS and Linux newbie so please bear with me!

I have successfully installed/configured CentOS 4.6 On my home laptop using virtual PC 2007. I'm a Windows user traditionally, but want to try Linux and teach myself some new skills. Although it does work, it is almost unusuable due to performance, for instance if i try to move the mouse cursor accross the screen, it takes between 2 and 6 seconds to respond, and then the mouse jumps accross the screen from A to B instantly. This lag was also present while i was installing the OS. I installed via text and not the GUI, and even when selecting language and keyboard layout via the keyboard, it was very laggy and took 5 or 6 seconds to respond to keystrokes. I also tried installing CentOS 5 and the same lag was present during set up / installation. (i don't know what happens after that as i can't actually get version 5 to boot, but i'll save that for another time). The lag is present 95% of the time, but every now and again the mouse seems to kick in and i will get a real time response for 2 or 3 seconds before the lag returns. I'm assuming that the problem is my hardware? Am i asking too much? or maybe theres a driver or fix for this? I have tried closing all non essential programs + services and i'm monitoring the task manager, CPU and memory is not maxed out so i'm not sure whats going on?

The laptop is a Dell Inspiron 1520 running Vista (32 bit), 1.86 Ghz with 1 Gig of RAM, plenty of HDD space. Just a standard out the box build with all the crap ripped off, AOL, google, DELL rubbish

I have tried playing about with the VPC settings, i have varied RAM size from 128MB to 512MB (and several in between), i have increased and reduced the VDD from 6Gig to 16Gig (and a few in between) but nothings working, it is still extremly slow and unresponsive.

I have searched the forums and web but can't see anything relating to this, apart from a few reviews saying that VPC 2007 is crap and slow. I don't know if it's VPC or my laptop but i'm hoping theres a fix or tweek?

thanks in advance!

foxb
Posts: 1924
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Performance issues with CentOS and VPC 2007

Post by foxb » 2008/03/20 00:17:52

I've used old version of Virtual PC in the past and the fix was to install drivers provided with VPC for the guest platform. This dramatically improved the performance.

Tip:

Do not use GUI on machine with less than 256M this will slow it...Also lower resolution will speed up the drawing
Do not expect full speed in virtual machine...

P.S. If you look here
http://www.microsoft.com/windows/products/winfamily/virtualpc/overview.mspx

You will see that linux is not officially supported guest OS

Maybe you will be interested in trying VMWare Server it supports Linux

Post Reply

Return to “CentOS 4 - Miscellaneous Questions”