Need help getting tar 1.15 installed on Centos 4.5

If it doesn't fit in another category, ask it here.
Post Reply
mericson
Posts: 1
Joined: 2007/11/13 17:09:20

Need help getting tar 1.15 installed on Centos 4.5

Post by mericson » 2007/11/13 17:42:20

CentOS 4.5 appears to have tar 1.14 installed, however I an RPM I'm installing requires tar 1.15.

Apparently tar 1.15 isn't available through the package repositories and an RPM file of tar 1.15 for CentOS I found requires a newer version of glibc than is in CentOS 4.5. tar 1.15 requires libc.so.6(GLIBC_2.4) but it appears that GLIBC_2.36 is what is in CentOS 4.5 distribution.

Any suggestions on how I can install tar 1.15 on CentOS 4.5?

K_Frye
Posts: 425
Joined: 2005/07/13 01:48:35
Location: Canada

Need help getting tar 1.15 installed on Centos 4.5

Post by K_Frye » 2007/11/13 19:02:32

[quote]
mericson wrote:
CentOS 4.5 appears to have tar 1.14 installed, however I an RPM I'm installing requires tar 1.15.

Apparently tar 1.15 isn't available through the package repositories and an RPM file of tar 1.15 for CentOS I found requires a newer version of glibc than is in CentOS 4.5. tar 1.15 requires libc.so.6(GLIBC_2.4) but it appears that GLIBC_2.36 is what is in CentOS 4.5 distribution.

Any suggestions on how I can install tar 1.15 on CentOS 4.5?[/quote]

Rebuild the src.rpm for tar that comes with CentOS 5.

Rebuilding src.rpms: http://linux.duke.edu/projects/nosrc-rpm/

pjwelsh
Posts: 2610
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Need help getting tar 1.15 installed on Centos 4.5

Post by pjwelsh » 2007/11/13 20:43:21

You should be able to just:
wget ftp://mirrors.kernel.org/centos/5/updates/SRPMS/tar-1.15.1-23.0.1.el5.src.rpm
rpmbuild --rebuild tar-1.15.1-23.0.1.el5.src.rpm
rpm -Uhv /usr/src/redhat/RPMS/i386/tar-1.15.1-23.0.1.i386.rpm

without issue for 4.5.

Post Reply

Return to “CentOS 4 - Miscellaneous Questions”