Page 1 of 1

Mouse Cursor & Screen Saver Interaction

Posted: 2006/09/03 21:49:04
by brock
I have been experiencing a problem with my mouse cursor for the last little while and just came across a solution to the problem.

When I first boot up CentOS, the mouse cursors appear properly. While I am actively using the computer they appear fine.

If I go away and the screen saver kicks in, I come back to find that my cursors are displayed as either solid black (bluecurve default set of cursors) or as a black mesh / screen (ComixCursors-Blue-Large-Slim cursor set).

Now, I fiddled with changing between several different mouse cursor sets but I was not able to clear this problem that way.

As the problem always occurred after the screen save had kicked in, I decided to took at the screen savers.

Menu Item : Applications - Preferences - Screen Saver

Note: I had my mouse cursor set to Comix for this test.

An interesting thing showed up...
When I selected a screen saver from the list in the dialog box, the mouse cursor instantly changed to reflect the selection of screen saver.
- If I chose a screen saver like Starwars, HyperTorus (solid), Bubbles3D or JigglyPuff, the mouse cursor became a black mesh / screen.
- If I chose a screen saver like Hypercube, Goop or Bubbles the mouse cursor became normal and looked like the proper mouse cursor samples.

I also noted, that the cursor was effected both while it was within the bounds of the dialog box and anywhere else on the screen.

So, there appears to be an interaction between the way that the mouse cursor is displayed and the screen saver selected.

The problem is not that this happens while the screen saver is active but that the effect persists after the screen saver becomes inactive. (i.e. after you move the mouse or press a key)

So, if you are having troubles seeing your mouse cursor because it has become solid black or a black mesh / screen, you might want to consider changing your screen saver to one that does not have that effect.

Hope this information provides you with a useful work-around in case this problem arises for you.

If anyone knows a more permanent solution, like a setting I should have adjusted, please post it...