Page 1 of 1

YUM-cannot rsync

Posted: 2006/03/08 19:38:35
by davesabath
Hi,

I'm having trouble getting rsync to work for centos 4.2. I created the directories /var/www/html/yum/{updates,base} . I copied the rpms from the 3 installation cd's to the base directory. I'm trying to use the stanford university rsync mirror. i imported the gpg key then i ran the following command in terminal:

rsync -avrt rsync://mirror.stanford.edu/yum/pub/centos/4.2/updates/i386/RPMS/ --exclude=debug/ /var/www/html/yum/updates

when i do that, i get the following error:

rsync: failed to connect to mirror.stanford.edu: Connection refused (111)
rsync error: error in socket IO (code 10) at clientserver.c(94)

What am I doing wrong?? Im new at Linux and I am following documentation that I found, but I keep running into this problem. Can someone help?

Dave

Re: YUM-cannot rsync

Posted: 2006/03/09 06:15:17
by WhatsHisName
[code]rsync -a rsync://mirror.stanford.edu::/mirrors/centos/4/updates/i386/RPMS/ /var/www/html/yum/updates/[/code]
Or, planning for the future:

[code]rsync -a rsync://mirror.stanford.edu::/mirrors/centos/4/updates/i386/RPMS/ /var/www/html/linux/centos/4/updates/i386/RPMS/[/code]

Re: YUM-cannot rsync

Posted: 2006/03/09 16:22:52
by davesabath
Its still not working. I still get a timeout or connection failed. Perhaps Im not writing the correct syntax. could you give me the exact wording of the command to rsync from the mirror to the appropriate directory on my centos box. see the previous thread.

Dave