Problem installing Oracle Database 10gR2 on CentOS 5

Installation and support for Oracle DB on CentOS.
Post Reply
Posts: 1
Joined: 2007/05/31 11:00:23

Problem installing Oracle Database 10gR2 on CentOS 5

Post by Hammi » 2007/05/31 12:43:32

Hello everyone !

First to say, I'm a newbie with CentOS. So please be kind with me. :-)

I'm trying to install Oracle Database 10gR2 on my newly installed CentOS 5 i386 (on an HP Proliant DL380G3). It should be the first step in setting up a complete "Enterprise Manager Grid Control" - server.

After solving some issues with missing packets I'm now confronted with a new problem after having successfully launched Oracle Universal Installer. OUI tells me, that "Oracle Database 10g is not certified on the current operating system". More precise :

Checking operating system requirements ...
Expected result: One of redhat-3,redhat-4,SuSE-9,asianux-1,asianux-2
Actual Result: redhat-CentOS release 5 (Final)
Check complete. The overall result of this check is: Failed <<<<

But I'm wondering that obviously many people in this forum managed it already to install Oracle DB 10g on CentOS, even on CentOS 5. So there seems to be a simple and convenient way to circumvent the problem. I noticed that that there's a important OUI-configuration-file under "/oracle/product/10.2.0/db_1/inventory/prereqs/db/refhost.xml", which seems to be used for checking allowed environments. But I don't understand the meaning of the included XML-Tags and how to modify them for properly matching to CentOS 5. And is this really the last problem need to be solved for OUI to install the DB and later on the Application Server for Grid Control ?

Can anyone help ?

Best regards,

Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: Problem installing Oracle Database 10gR2 on CentOS 5

Post by foxb » 2007/05/31 15:41:42

I've installed Oracle XE ( if I'm not mistaken) on CentOS 5 and it worked, but RHEL5/CentOS5 are not certified for Oracle.

So if you need support they will refuse it until you use certified OS.

CentOS 4.5 will be your choise.

Posts: 29
Joined: 2006/03/16 22:27:28

Problem installing Oracle Database 10gR2 on CentOS 5

Post by dizwell » 2007/06/08 23:27:49

I've got a complete installation guide for Oracle Enterprise Edition on Centos 5 available [url=]at my website[/url].

That specific article was actually more interested in making Centos 5 usable as a home distro, so it talked a lot about Beryl/Compiz, fonts, media players and so on. But down in Section 8, you'll find what you're after.

Indeed, there are a whole slew of
[url=]Oracle-installation-specific articles elsewhere on the site[/url], just in case you ever change distros or fancy doing 64-bit instead of 32-bit.

It is of course never supported (by Oracle) to install Oracle EE on any flavour of Centos at all, but that doesn't mean it can't be done -and it's certainly shouldn't make you install the XE version instead, which is crippled, cut-down and totally non representative of how 'real' Oracle installations look like and get administered.

Posts: 6
Joined: 2007/09/07 00:05:40

Re: Problem installing Oracle Database 10gR2 on CentOS 5

Post by Ejant » 2007/09/07 00:10:38

maybe you should try
./runInstaller -ignoreSysPrereqs

i hope it will help

btw, i´m new here, so hi to all!
ps: does anyone has installed Oracle 9i on Centos5??
thanks in advanced
greetz, Ejant

Posts: 1
Joined: 2008/05/21 15:08:58

Re: Problem installing Oracle Database 10gR2 on CentOS 5 (Solution)

Post by helloworld » 2008/05/21 15:47:16

for novice CentOS users who may find this post while trying to install Oracle 10g R2 on CentOS (5.1, but the version doesn't matter):

replace the content of file /etc/redhat-release (for 5.1, by default: CentOS release 5 (Final) ) with one of the certified releases (e.g., currently: redhat-4, check [Certified Versions] in $SOURCE/install/oraparam.ini )

the installation then goes without problems, except for a warning about DHCP, for those who don't have their own domain ¦-)
:) or DSL... (:

/!\ don't forget to restore the file after OUI is done /!\

Post Reply

Return to “CentOS 4 - Oracle Installation and Support”