Getting X working on Sparc CentOS 4.3

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
mehornayc
Posts: 2
Joined: 2006/10/17 14:44:26

Getting X working on Sparc CentOS 4.3

Post by mehornayc » 2006/10/17 20:39:23

I have recently downloaded and installed the Sparc beta for CentOS 4.3. Everything is working except X, refusing to start because of not finding a mouse. I have tried '/dev/mouse0', '/dev/psaux', and '/dev/mice', all without success. Has anyone gotten this to work?

My hardware is an Ultra-60 with Creator3D graphics and a PS/2 Sun type 6 keyboard/mouse.

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Getting X working on Sparc CentOS 4.3

Post by foxb » 2006/10/18 14:01:00

If there is no answer soon try asking at dev mailing list (you use beta)

By the way can you see it recognized in dmesg??

Did you try configuring it? (setup --> mouse)

mehornayc
Posts: 2
Joined: 2006/10/17 14:44:26

Re: Getting X working on Sparc CentOS 4.3

Post by mehornayc » 2006/10/18 16:16:01

Thanks for the response.

Yes, it shows up in the 'dmesg' output:

(lines omitted)
ebus0: [auxio] [power] [SUNW,pll] [sc] [se] [su] [su] [ecpp] [fdthree] [eeprom] [flashprom] [SUNW,CS4231]

(lines omitted)

mice: PS/2 mouse device common for all mice
input: Sunt Type 5 keyboard on su/serio1
input: Sun Mouse on su/serio0

---

When I run 'setup' and select 'mouse', I see several choices for PS/2, USB, and serial mice, and a 'Sun Mouse' choice.

(Selecting Sun Mouse)

In /var/log/messages:

winnie gpm: gpm shutdown succeeded
winnie gpm: inputattach shutdown failed
winnie gpm[2522]: *** info [startup.c(95)]:
winnie gpm[2522]: Started gpm successfully, Entered daemon mode.
winnie gpm: gpm startup succeeded

(Selecting Generic 3-Button mouse PS/2)

winnie gpm: gpm shutdown succeeded
winnie gpm[2539]: *** info [startup.c(95)]:
winnie gpm[2539]: Started gpm successfully, Entered daemon mode.
winnie gpm[2539]: *** info [mice.c(1766)]:
winnie gpm[2539]: imps2: Autodetected intellimouse PS/2
winnie gpm: gpm startup succeeded

It looks like it found a PS/2 Intellimouse, but how do I put this information into the 'xorg.conf' file? If I do "X -configure", I end up with:

Xorg is not able to detect your mouse.
Edit the file and correct the Device.

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: Getting X working on Sparc CentOS 4.3

Post by foxb » 2006/10/19 13:38:59

Is the mouse functional in text mode??

/dev/mouse should be symlink to your mouse

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”