x86_64 install problems

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
Posts: 2
Joined: 2005/05/22 14:53:57

x86_64 install problems

Post by altman » 2005/05/22 15:54:25

i'm preparing a more complete description of my testing and findings, that i expect to post probably later today or tomorrow. in the meantime, i wanted to send up a flare to see if anyone has had a similar experience.

i just built a new machine (my first 64-bit box, but not my first build), that includes the following:

GIGABYTE GA-K8N Ultra-9 (nForce4 Ultra chipset)
AMD Athlon 64 3800+
2GB Corsair XMS DDR 3200
WD Raptor 36GB 10K SATA
MSI Geforce 6600GT PCI-E x16
Antec True550 550W power supply

i am, so far, unable to get the x86_64 install fully operational. here are the highlights:

- downloaded the centos 4.0 x86_64 iso's and burned cd's (the md5sums checked against the published values).

- uncovered a peculiarity with the sata and the onboard raid controller. drive showed up as physically there, but still got a "no device" message. small print in the motherboard manual says for a non-raid configuration, "please select jbod mode from the raid bios". apparently this gave the controller the logical view it expected, because the drive worked fine afterward.

- graphical install (of centos) was garbled once it fired off x. tried various resolutions and a no-probe with no success. /tmp/X.log showed module errors (unable to load, various modules not found) and a warning about memory allocation. basically, x failed to start.

- went ahead with a text-based install (since i was ultimately going to install the nvidia driver by hand later anyway). this proceeded fine (partitioning, formatting, install). on reboot, x came up garbled again.

- booted to single user (which seemed fine). went to run level 3 (which also seemed fine) to go ahead and update to the 5.0.5 kernel, and then install the nvidia 7174 driver. as expected, the nvidia installer needed to build a kernel interface. the interesting thing is it complained about the current kernel having memory problems that the driver was going to try to work around, and recommended i upgrade to the 2.6.11 version. other than that complaint, the nvidia driver install completed as expected. however, starting x was still a no-go.

at that point, i was beginning to suspect either i had screwed something up or there was a hardware failure of some sort. in an effort to rule out hardware failures, i started over with an install of centos 4.0 i386. the graphical install worked fine, and after installing the nvidia driver x is behaving exactly as i would expect. (in fact, i'm sending this message from the machine right now.)

i'm reasonably confident at this point there isn't anything wrong with the hardware, since the i386 version runs without error or complaint.

i found in the forum a reference to iso's failing to verify, but the install working. my case seems to be the opposite. the iso's seem to be good (both in terms of the md5sums, and the media check), but something in the install isn't working. my hunch is some sort of driver conflict, perhaps something to do with the 64-bit memory mapping, but i'm not sure. i'm planning to go back through the x86_64 install, documenting the details, later today.

in the meantime, if anybody has seen anything along these lines or has any thoughts, i'd be interested in hearing.


Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”