lvcreate snapshot freezes

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
Posts: 1
Joined: 2005/05/11 23:51:03

lvcreate snapshot freezes

Post by imemyself » 2005/05/12 00:04:31

I'm having some very big issues while trying to create an LVM snapshot of my root partition. After I run lvcreate, I can do some things(like move the mouse around in Gnome via XDMCP at first, but eventually everything(even the local terminal and CTRL-ALT-Fx) stops. It does not always do this; it occurs maybe half the time. When it works, it seems to work in just a few seconds. When this happens, I have to do a hard reset, which is rather fun with ext3 and its even more so because I was just trying to make a backup(so, the time since the last backup is at its max). I am running CentOS 4(fully up2date), on a Dell SC1420, with one 2.8 ghz Xeon w/ EM64T and HT(running SMP kernel). I have 512 mb of RAM, and an 80 gb SATA HDD. Has anyone here experienced anything similar to this, or have an idea of what could be the culprit? I don't see anything in the system log that looks like it was from around the time that this happened. Thanks.

The exact command I tried to run was lvcreate -L1000M -s -n RootBak /dev/LVM/Root

Upon reboot, RootBak was in /dev/LVM.

This is information on my LVM partitions if it helps:
lvm> lvs
LV VG Attr LSize Origin Snap% Move Copy%
Root LVM -wi-ao 19.53G
Swap LVM -wi-ao 1.00G
NetStore Storage -wi-ao 19.53G
lvm> pvs
PV VG Fmt Attr PSize PFree
/dev/hda1 Storage lvm2 a- 55.89G 36.36G
/dev/sda2 LVM lvm2 a- 48.81G 28.28G

I have not tried making snapshots of the NetStore lv(on a separate PATA drive), should I?

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”