OpenSSL conflicts with itself

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
novakane007
Posts: 1
Joined: 2005/03/30 16:19:17

OpenSSL conflicts with itself

Post by novakane007 » 2005/04/06 21:20:36

error:
file /usr/share/man/man1/asn1parse.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1

When I try to run 'yum -y groupinstall gnome' I get the above. It's trying to install the i686 version of openssl and it's conflicting with the amd86_64 version. Any ideas?

z00dax
Posts: 220
Joined: 2004/11/30 22:04:52
Location: London - UK
Contact:

OpenSSL conflicts with itself

Post by z00dax » 2005/04/17 12:15:35

On a clean x86_64 box, I am able to 'yum groupinstall gnome ' with no problems.

do you have a fresh install or is it a upgrade / update from somewhere ?

apnu
Posts: 8
Joined: 2005/05/19 17:33:29

Re: OpenSSL conflicts with itself

Post by apnu » 2005/05/19 17:40:09

I am getting the same error, but with a different set of circumstances.

This is a fresh minimal install of CentOS 4. First I did "yum update" then "yum remove sendmail" The package "openssl-0.9.7a-43.1" is already on the system at this point. Then "yum install postfix imap imap-devel cyrus-sasl cyrus-sasl-gssapi cyrus-sasl-md5 cyrus-sasl-plain cyrus-sasl-devel"

Which resulted in the following:
[quote]
Transaction Listing:
Install: cyrus-sasl.i386 0:2.1.19-5.EL4 - base
Install: cyrus-sasl-devel.x86_64 0:2.1.19-5.EL4 - base
Install: cyrus-sasl-gssapi.i386 0:2.1.19-5.EL4 - base
Install: cyrus-sasl-gssapi.x86_64 0:2.1.19-5.EL4 - base
Install: cyrus-sasl-md5.i386 0:2.1.19-5.EL4 - base
Install: cyrus-sasl-plain.i386 0:2.1.19-5.EL4 - base
Install: postfix.x86_64 2:2.1.5-4.2.RHEL4 - update

Performing the following to resolve dependencies:
Install: cracklib.i386 0:2.7-29 - base
Install: cracklib-dicts.i386 0:2.7-29 - base
Install: e2fsprogs.i386 0:1.35-11.6.EL4 - base
Install: gdbm.i386 0:1.8.0-24 - base
Install: glib2.i386 0:2.4.7-1 - base
Install: krb5-libs.i386 0:1.3.4-12 - update
Install: libselinux.i386 0:1.19.1-7 - base
Install: openldap.i386 0:2.2.13-2 - base
Install: openssl.i686 0:0.9.7a-43.1 - base
Install: pam.i386 0:0.77-65.1 - base
Install: zlib.i386 0:1.2.1.2-1 - base
Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Check Error: file /usr/share/man/man1/asn1parse.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1
file /usr/share/man/man1/nseq.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1
file /usr/share/man/man1/s_client.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1
file /usr/share/man/man1/s_server.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1
file /usr/share/man/man1/sslpasswd.1ssl.gz from install of openssl-0.9.7a-43.1 conflicts with file from package openssl-0.9.7a-43.1[/quote]

on edit:
I seem to have gotten around it. I did "rpm -e --nodeps openssl" to get the offending openssl package off the system than I ran the long yum line above and everything installed. Still it is weird to have openssl conflict with itself.

z00dax
Posts: 220
Joined: 2004/11/30 22:04:52
Location: London - UK
Contact:

Re: OpenSSL conflicts with itself

Post by z00dax » 2005/05/19 23:55:23

seems to be a multilib issue, pkgs from one arch are overlaping another, with openssl you should be a little more careful since pkgs are provided which do the same thing, even within the x86 32 bit arch.

hughesjr
Site Admin
Posts: 251
Joined: 2004/12/05 01:51:26
Location: Corpus Christi, Texas, USA
Contact:

Re: OpenSSL conflicts with itself

Post by hughesjr » 2005/05/20 20:17:39

The problem is that is multi-lib ... and the libraries are different BUT the man (help files) are the same.

I would probably have force installed the openssl.i686 RPM.

That way you still have the 64-bit and the 32-bit libraries ... the DOCs are really not that important (and are the same anyway)

cormander
Posts: 100
Joined: 2005/05/16 21:27:57
Location: Utah
Contact:

Re: OpenSSL conflicts with itself

Post by cormander » 2005/05/20 20:21:50

Just a note on this...

DO NOT upgrade with -U on this, force a install ( -i ) statement or else you'll probably end up screwing with a ton of things that use openssl.

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”