x86_64 CDs appear to fail validation.

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
ladar
Posts: 5
Joined: 2005/03/28 20:50:51
Contact:

x86_64 CDs appear to fail validation.

Post by ladar » 2005/03/31 22:35:30

Gents --

I hit a problem installing Cent OS 4 the other day on an x86_64 system, and wanted to post my findings to this board for comment. Specifically, I couldn't get anaconda to verify the integrity of CDs. All four CDs failed, including two seperate copies of disc one. The md5sums on the ISOs matched up, but still anaconda failed to verify.

Even more strangely, if I boot the i386 disc on an i386 system, and then have anaconda attempt to verify the x86_64 discs, they all pass.

I did proceed with the install despite the disc failure, and I experienced no problems. This makes me suspect the anaconda configuration as the culprit. I say this because I am under the impression that each RPM is verified against a GPG key as it is installed. If the disc was in fact corrupt, the RPM transaction should have failed, no? Granted I didn't install many of the packages, so it is possible the disc was corrupted, but that the packages I installed were fine.

Can anyone else reproduce this behaviour?

L~

jamitupya
Posts: 2
Joined: 2005/01/26 12:41:47
Contact:

Re: x86_64 CDs appear to fail validation.

Post by jamitupya » 2005/04/27 11:10:05

i cant reproduce this exactly ...but i dloaded the 4x CD's from 5 different locations + the dvd from 2 different torrent sources and the discs still fail... but these fail entirely.... currupted install etc

I finally managed to install it from cd's after multiple burning attempts etc and i select custom install and specify NO gui ...and once the iunstall is finished .. *BAM* 64bit os with xwindows installed ........ kind of annoying....

i've migrated my 64Bit boxes back to 3.4 :-)

z00dax
Posts: 220
Joined: 2004/11/30 22:04:52
Location: London - UK
Contact:

Re: x86_64 CDs appear to fail validation.

Post by z00dax » 2005/04/27 12:36:22

[quote]jamitupya wrote:
i cant reproduce this exactly ...but i dloaded the 4x CD's from 5 different locations + the dvd from 2 different torrent sources and the discs still fail... but these fail entirely.... currupted install etc[/quote]

Can you please let me know which mirrors you downloaded from ? also can you post the md5sum's from the downloaded .iso. We have a lot of people using and running x86_64 CentOS4 with no problems. Also, can you please point out the different torrent sources ? There is only 1 torrent tracker for the release. So I am not sure what it is that you were downloading....

A good guess on my part would be bad media that you are writing to... alternatively a defective setup / configs in your CD Burning app ( what do you use ? )

[quote]I finally managed to install it from cd's after multiple burning attempts etc and i select custom install and specify NO gui ...and once the iunstall is finished .. *BAM* 64bit os with xwindows installed ........ kind of annoying....[/quote]

If you select a package which in turn needs the gui installed, that will get pulled in as well ( which seems to be the issue you hit ), but a simple ' yum grouperase ' would have removed the entire pkg group you didnt need.

z00dax
Posts: 220
Joined: 2004/11/30 22:04:52
Location: London - UK
Contact:

Re: x86_64 CDs appear to fail validation.

Post by z00dax » 2005/04/27 12:38:45

[quote]
ladar wrote:
Gents --
I hit a problem installing Cent OS 4 the other day on an x86_64 system, and wanted to post my findings to this board for comment. Specifically, I couldn't get anaconda to verify the integrity of CDs. All four CDs failed, including two seperate copies of disc one. The md5sums on the ISOs matched up, but still anaconda failed to verify.[/quote]

This issue has been covered quite extensively in the Mailing Lists, I suggest you look there for detailed answers and an explanation on what is going on. ( [url=http://lists.centos.org/pipermail/centos/]http://lists.centos.org/pipermail/centos/[/url] )

merlin42
Posts: 4
Joined: 2005/05/17 15:41:38

Re: x86_64 CDs appear to fail validation.

Post by merlin42 » 2005/05/17 15:48:03

I have exactly the same situation, the disks fail verification but seem to install just fine.
The MD5SUMs of the .iso files match the published ones.

Maybe I'm blind, but I couldn't find anything relevant with a quick scan through:
http://lists.centos.org/pipermail/centos/

Could someone point me to a specific message to get me started?

osde-info
Posts: 89
Joined: 2005/02/08 09:26:48
Location: LGW UK

Re: x86_64 CDs appear to fail validation.

Post by osde-info » 2005/06/20 09:31:59

Seems to be a problem with kernel,driver,DMA and older CD drives such as the 1999 PHILIPS 4x4x24 cd burner I had put in my PIII HP Vectra VE. Red Hat 8 installs perfectly but CentOS 4 keeps saying there are corrupt files. I have now replaced the CD/RW drive with a 2004 LG 52x24x52 and install has gone perfectly.

See
http://www.centos.org/modules/newbb/viewtopic.php?topic_id=402&forum=27&post_id=2864#forumpost2864
http://www.centos.org/modules/newbb/viewtopic.php?topic_id=389&forum=27&post_id=2863#forumpost2863

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”