PPC failed install

Support for the other architectures (X86_64, s390(x) and PowerPC)
Post Reply
justinkelly
Posts: 5
Joined: 2005/03/17 09:39:00
Location: melbourne

PPC failed install

Post by justinkelly » 2005/03/17 10:05:37

Hi All

Ive come across the following error when attempting to install CentOS 4beta1 PPC on my G4 PowerMac at the partitioning stage of the install

[code]
Attempt to read sector 16-18 outside of partition on /dev/hdb
[/code]

it comes up with an Ignore and Cancel button, if you just keep on clicking ignore and select Auto-partition it fails to get past the partition stage with an error can setup /home or something (didnt write it down), if you select Ignore and use Disk-Druid you can set up the partition and install CentOS but once the systems reboots im presented with my old Ubuntu yaboot prompt.

anyone got any ideas?

also is there a yaboot config section or something i missed in the install process?

note:
hda is my current ubuntu install
hdb is Mac OS9 and Mac OSX


Cheers

Justin

z00dax
Posts: 220
Joined: 2004/11/30 22:04:52
Location: London - UK
Contact:

PPC failed install

Post by z00dax » 2005/03/17 11:45:04

as long as you create the apple boot partition, yaboot and the bootloader are setup automatically at the end of the install stage. if you still need to manually setup the bootloader, take a look at these notes : http://www.bytebot.net/geekdocs/ibook/fedorappc.html - although done for fedora, they work for CentOS4/beta as well.

re: your partition issue -> I havent seen that before. can you run a 'parted print' for hda and hdb, and paste it here into a msg ?

justinkelly
Posts: 5
Joined: 2005/03/17 09:39:00
Location: melbourne

Re: PPC failed install

Post by justinkelly » 2005/03/17 21:50:40

thanks z00dax

i reinstalled - still got the errors when i came to the partitioning again but this time i used Disk Druid and deleted all my existing partitions including the bootstrap and recreated them, and the installed worked :)

just one more thing

after i logging into centos i changed the yaboot setup in /etc/yaboot.conf

but when i went to initialise the bootstrap using

[code]
mkofboot
[/code]
and

[code]
ybin -v
[/code]

i got 'command cant be found'

are these yaboot applications installed by default in centos ppc

note: i did the workstation install not the full install due to time constraints

will paste my 'parted print' on this forum when im back on my ppc tonight

cheers

justin

Post Reply

Return to “CentOS 4 - X86_64,s390(x) and PowerPC Support”