Page 1 of 1


Posted: 2006/10/26 12:41:56
by thim
I want to install Libssh2 so i can use the ssh exec via PHP as a certain user.

I followed the tutorial on PHP.NET but i had no succes.
I couldn't even compile. Everything was ok during the configure but during the MAKE i always get following error
gcc: /usr/include: linker input file unused because linking not done
channel.c:1253:10: /usr/include: No such file or directory
channel.c:71: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.

I installed an RPM from the DAG repo again no succes.
[code]PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/' - /usr/lib/php/modules/ undefined
symbol: zend_hash_add_or_update in Unknown on line 0

Is there anybody who got it working on a Centos 4.4 with apache 2 and PHP5 (installed through yum via centosplus repo)

Any help or pointers are welcome.


Posted: 2006/10/29 17:09:14
by thim
I fixed it myself

There was a conflict by an older version of PHP (compiled from source)
I forgot to remove it completely.

After the cleaning i tried it again by using the dag repo and phpize --with ssh2
and after the restart it worked like a charm


Posted: 2006/11/02 18:04:54
by thim
Another problem

There is no libssh2 aviable for x86_64!

Who knows were to get this libssh2 for x86_64?

I tried to compile it from source but it kept complaining about missing libcrypto but i can't seem to get it installed

Who can help me ?