how to install Apache-SSL on centos 4.1

Support for webhosts that use CentOS
Post Reply
abhijitnt
Posts: 6
Joined: 2005/08/29 06:28:09

how to install Apache-SSL on centos 4.1

Post by abhijitnt » 2005/12/26 12:17:21

Hi guys
I am using centOS 4.1 & apache 2.0.51 & working fine.
now I want to make a secure site with SSL cert.
can I use the mod_ssl & can create a ssl server or I have to remove 2.0.51 7 install apache-SSL 1.3 to work as SSLserver?
cant I go with mod_ssl & stick to 2.0.51, if not why ?

I have tried to install apache-ssl 1.3 but gives following error:-

rpm -ivh apache-ssl-1_3_4-1_31-1_i386.rpm
error: Failed dependencies:
SSLeay >= 0.9.0b is needed by apache-ssl-1.3.4-1.31-1.i386
libcrypto.so.0 is needed by apache-ssl-1.3.4-1.31-1.i386
libssl.so.0 is needed by apache-ssl-1.3.4-1.31-1.i386

How to fulfill the above dependencies.

Regards
Abhijit

Evolution
Posts: 229
Joined: 2005/02/22 16:10:54
Location: Houston Texas
Contact:

how to install Apache-SSL on centos 4.1

Post by Evolution » 2006/01/06 18:31:38

You don't need to use the apache-ssl rpm you're attempting, and to do so would pretty royally screw your system. all you need to do is have mod_ssl installed, so 'yum install mod_ssl' if you don't have it already. Then cd to /etc/httpd/conf/
from there you'll see a Makefile that will let you create various types of ssl certificates, for requesting one from Verisign etc, to testcert to get things up and running. make testcert will start you off with a self-signed certificate.

Post Reply

Return to “CentOS 4 - Webhosting Support”