SELinux and eAccelerator

Support for security such as Firewalls and securing linux
Post Reply
spooky
Posts: 1
Joined: 2006/09/07 19:13:57
Contact:

SELinux and eAccelerator

Post by spooky » 2006/09/07 19:24:14

Greetings...

I have a Centos 4.4 up2date...

I'm trying to get SELinux working with eAcelerator

I have the eaccelerator from DAG repository

I get this error in the logs:

Sep 7 22:10:17 localhost kernel: audit(1157656217.111:4855): avc: denied { read write } for pid=30281 comm="sh" name="eaccelerator.apache2handler7230.sem.4YIYaP" dev=dm-0 ino=1753136 scontext=root:system_r:httpd_sys_script_t tcontext=root:object_r:httpd_tmp_t tclass=file
Sep 7 22:10:17 localhost kernel: audit(1157656217.116:4856): avc: denied { read } for pid=30282 comm="cc1" name="glibctestWI7NBD" dev=dm-0 ino=1753155 scontext=root:system_r:httpd_sys_script_t tcontext=root:object_r:httpd_tmp_t tclass=file

I wasn't able to find anything on the net about it... I also tried difference chcon, setsebool... nothing made it dissapear.

However... eaccelerator seems to be working... because the /var/cache/php-eaccelerator has content... and phpinfo gives the following:


eAccelerator supportenabled
Version 0.9.3
Caching Enabled true
Optimizer Enabled true
Memory Size 33,554,368 Bytes
Memory Available 1,360 Bytes

Memory Allocated 33,553,008 Bytes
Cached Scripts 295
Removed Scripts 0
Cached Keys 13


DirectiveLocal ValueMaster Value

eaccelerator.cache_dir/var/cache/php-eaccelerator/var/cache/php-eaccelerator
eaccelerator.check_mtime11
eaccelerator.compress11
eaccelerator.compress_level99
eaccelerator.contentshm_and_diskshm_and_disk

eaccelerator.debug00
eaccelerator.enable11
eaccelerator.filterno valueno value
eaccelerator.keysshm_and_diskshm_and_disk
eaccelerator.name_spaceno valueno value

eaccelerator.optimizer11
eaccelerator.sessionsshm_and_diskshm_and_disk
eaccelerator.shm_max00
eaccelerator.shm_only00
eaccelerator.shm_prune_period00

eaccelerator.shm_size00
eaccelerator.shm_ttl36003600

Post Reply

Return to “CentOS 4 - Security Support”