Denyhosts on CentOS 4.3

Support for security such as Firewalls and securing linux
Post Reply
rawoo
Posts: 5
Joined: 2006/05/03 19:52:00

Denyhosts on CentOS 4.3

Post by rawoo » 2006/05/09 00:50:40

Has anyone had success in installing the latest version of Denyhosts on CentOS 4.3?

Seems it requires Python 2.4 which isn't available in the 4.3 repositories, and a new build from source breaks both yum and up2date.

Anyone?

kekkemon
Posts: 2
Joined: 2006/05/14 18:02:19

Re: Denyhosts on CentOS 4.3

Post by kekkemon » 2006/05/14 18:08:20

Well you haven looked enough ;-)
Ive run Denyhost 2.4b but I dont remember if i use the rpm or if i compiled it by my self :-o
Anyway, take a look [url=http://sourceforge.net/project/showfiles.php?group_id=131204]here[/url] and take either try the source or DenyHosts-2.4b-python2.3.noarch.rpm
gl hf

robrecc
Posts: 4
Joined: 2006/05/28 01:03:18

Re: Denyhosts on CentOS 4.3

Post by robrecc » 2006/05/28 01:09:49

I just did a new install of centos 4.3 and first thing grabbed the denyhost source and no problems at all

kaskinha
Posts: 33
Joined: 2005/12/31 13:02:00
Contact:

Re: Denyhosts on CentOS 4.3

Post by kaskinha » 2006/06/05 20:11:26

I have these errors when I start

Can't read: /private/var/log/system.log
[Errno 2] No such file or directory: '/private/var/log/system.log'
Error deleting DenyHosts lock file: /var/lock/subsys/denyhosts
[Errno 2] No such file or directory: '/var/lock/subsys/denyhosts'
starting DenyHosts: /usr/bin/denyhosts.py --daemon --config=/usr/share/denyhosts/denyhosts.cfg

kekkemon
Posts: 2
Joined: 2006/05/14 18:02:19

Re: Denyhosts on CentOS 4.3

Post by kekkemon » 2006/08/06 16:33:59

I think you have made a misstake when you configured denyhosts.cfg.
Check in the begining of that file and make sure you use the Redhat/Fedora core log parameter.

K_Frye
Posts: 425
Joined: 2005/07/13 01:48:35
Location: Canada

Denyhosts on CentOS 4.3

Post by K_Frye » 2006/08/08 18:43:46

[quote]
rawoo wrote:
Has anyone had success in installing the latest version of Denyhosts on CentOS 4.3?

Seems it requires Python 2.4 which isn't available in the 4.3 repositories, and a new build from source breaks both yum and up2date.

Anyone?[/quote]

Use the rpm from Karan's repo. It works great.

http://centos.karan.org/el4/extras/stable/i386/RPMS/repodata/repoview/denyhosts-0-2.5-1.el4.kb.html

Post Reply

Return to “CentOS 4 - Security Support”