CUPS web interface not accessible from another machine

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
weslowsk
Posts: 51
Joined: 2008/04/09 04:45:34
Location: Canada

CUPS web interface not accessible from another machine

Post by weslowsk » 2008/09/28 03:56:35

Hi,

I was previously able to access the CUPS web interface from another machine and now I can't. The only thing I can remember that changed was that I'm now connecting to the machine on another network interface (i.e. I used to connect to it on 192.168.3.x and now I connect to it on the 192.168.1.x network.
I took that into account and updated cupds.conf to make sure that the server allows IPs in that range.

I checked (using netstat) and the server is listening on port 631 on all interfaces but when I try to connect from another machine's browser, it always fails, like as if it isn't listening.

Any thoughts on what it could be?

Kevin

weslowsk
Posts: 51
Joined: 2008/04/09 04:45:34
Location: Canada

Re: CUPS web interface not accessible from another machine

Post by weslowsk » 2008/09/28 04:25:38

I had previously only tried it with FF and IE, but now I just tried it with IE and it worked! But using Opera and FF both, the connection failed...

Now, WTF?!

herrold
Posts: 100
Joined: 2005/03/19 22:14:28
Contact:

CUPS web interface not accessible from another machine

Post by herrold » 2008/09/28 04:47:44

This is manually configurable (several options) in the form:
allow from 127.0.0.1

in /etc/cups/cups.conf

add the local subnet, usually in the form:
allow from 192.168.0

(note the absence of a last octet implies from 0 to 255, usually what is wanted)

The cups service will also need to be restarted.

This may ALSO be editted in the configuration options screen in the localhost:631 interface.

-- Russ herrold

weslowsk
Posts: 51
Joined: 2008/04/09 04:45:34
Location: Canada

Re: CUPS web interface not accessible from another machine

Post by weslowsk » 2008/09/28 04:50:49

I've already gone through that. Check my last post re: only IE working...

weslowsk
Posts: 51
Joined: 2008/04/09 04:45:34
Location: Canada

Re: CUPS web interface not accessible from another machine

Post by weslowsk » 2008/09/28 05:09:39

My problem ended up being my software firewall - comodo

sorry for not checking this earlier...

Post Reply

Return to “CentOS 4 - Server Support”