Outgoing POP server not responding

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Outgoing POP server not responding

Post by ToastyHost » 2008/09/03 07:44:43

My customers and myself are having issues sending emails via the POP3 server.
My stats are:
WHM 11.23.2 cPanel 11.23.6-R26881
CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0

I've reset EXIM, POP3, APACHE and thinking of rebuilding... i'm a little lost :-(

What should be my next move?

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Outgoing POP server not responding

Post by gerald_clark » 2008/09/03 13:04:55

You don't send mail via POP.

ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Re: Outgoing POP server not responding

Post by ToastyHost » 2008/09/03 13:33:07

IMAP?

okay, i tried to recompile apache, but there was a problem with yum... so i updated yum, recompiled apache, and then rebooted the server... It's still not working.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Outgoing POP server not responding

Post by gerald_clark » 2008/09/03 13:45:58

You send mail via an smtp server such as sendmail.
POP and IMAP are used to retrieve mail from a server.

Did you read the required posts?
http://www.centos.org/modules/newbb/viewforum.php?forum=47
I would recommend you buy the Linux Bible listed.

ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Re: Outgoing POP server not responding

Post by ToastyHost » 2008/09/04 02:46:20

right well, i'm starting to doubt that it is the smtp after all, i can send from within webmail. maybe it's a problem connecting to port 25?

ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Re: Outgoing POP server not responding

Post by ToastyHost » 2008/09/04 03:56:08

more information:

cannot "telnet 25" from command prompt,
returns: "Connecting to ... Could not open connection to the host, on port 25 : Connect Failed."

it also returns a similar result from inside the server (directed at localhost 25)

ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Re: Outgoing POP server not responding

Post by ToastyHost » 2008/09/04 04:11:47

more evidence:

[root@**** ~]# telnet mail.example.com.au 25
Trying 117.***.***.155...
Connected to mail.example.com.au (117.***.***.155).
Escape character is '^]'.
220-dart.example.com.au ESMTP Exim 4.69 #1 Thu, 04 Sep 2008 14:04:57 +1000
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
ehlo mail2.example.com.au
250-dart.example.com.au Hello mail2.example.com.au [117.***.***.155]
250-SIZE 52428800
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
mail from:
250 OK
rcpt to:
550-(mail2.example.com.au) [117.***.***.155] is currently not permitted to
550-relay through this server. Perhaps you have not logged into the pop/imap
550-server in the last 30 minutes or do not have SMTP Authentication turned on
550 in your email client.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Outgoing POP server not responding

Post by gerald_clark » 2008/09/04 13:21:08

[quote]
ToastyHost wrote:
more information:

cannot "telnet 25" from command prompt,
returns: "Connecting to ... Could not open connection to the host, on port 25 : Connect Failed."

it also returns a similar result from inside the server (directed at localhost 25)[/quote]

Not running sendmail or iptables blocking port 25?

michaelnel
Posts: 1478
Joined: 2006/05/29 16:50:11
Location: San Francisco, CA

Re: Outgoing POP server not responding

Post by michaelnel » 2008/09/04 17:13:41

As stated many times in this forum, sendmail does not listen on port 25 by default. You have to make a change to /etc/mail/sendmail.mc and regenerate the sendmail.cf before it will listen on port 25.

I believe this is also true of postfix.

In this case, since nothing appears to be listening on localhost port 25, it looks like neither postfix or sendmail are enabled though.

ToastyHost
Posts: 7
Joined: 2008/09/03 07:39:19
Contact:

Re: Outgoing POP server not responding

Post by ToastyHost » 2008/09/08 12:12:11

I'm not running Sendmail... I'm pretty sure i'm running EXIM. Is this not the standard mail server for CentOS 4.6?

Should i try installing one of Sendmail or PostFix? Do you think this would solve my issues?
I really don't know where to go next... I've spend days and days sorting through a massive amount of information, understanding little.

Post Reply

Return to “CentOS 4 - Server Support”