HTTPD Failed after YUM update

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
bmikesell
Posts: 3
Joined: 2008/07/21 14:07:31

HTTPD Failed after YUM update

Post by bmikesell » 2008/07/21 14:47:57

This is the error I get:

Starting httpd: [Mon Jul 21 08:45:56 2008] [error] is only avaliable with the XS version at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9\nBEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9.\nCompilation failed in require at (eval 8) line 3.\n
[Mon Jul 21 08:45:56 2008] [error] Can't load Perl module Compress::Zlib for server myserver:0, exiting...


I have OCS inventory installed and I think it might be something with that but I'm not sure. I tried to install yum install perl-Compress-Zlib but it says nothing to do. Any Ideas

bmikesell
Posts: 3
Joined: 2008/07/21 14:07:31

Re: HTTPD Failed after YUM update

Post by bmikesell » 2008/07/21 16:39:31

I get the same error when I do this

# perl -e 'use Compress::Zlib'
is only avaliable with the XS version at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/Zlib.pm line 9.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

User avatar
toracat
Forum Moderator
Posts: 7439
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: HTTPD Failed after YUM update

Post by toracat » 2008/07/21 16:49:55

You might have two conflicting versions of perl installed on your system. What is the output of:

rpm -qf `locate Zlib.pm | grep Compress`

bmikesell
Posts: 3
Joined: 2008/07/21 14:07:31

Re: HTTPD Failed after YUM update

Post by bmikesell » 2008/07/21 17:10:40

I fixed it!!

I entered the CPAN utility and ran this:

force install Scalar::Util

The error only effects CentOS 4 I think after a perl upgrade
:-)

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: HTTPD Failed after YUM update

Post by gerald_clark » 2008/07/21 17:19:50

CPAN probably caused your problem.
CPAN is not really compatible with RPMs.
You should find an RPM version of your needed module at one of the recommend repositories.

User avatar
toracat
Forum Moderator
Posts: 7439
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: HTTPD Failed after YUM update

Post by toracat » 2008/07/21 18:10:17

As Gerald said, using CPAN is not a solution. Please have a look at this thread:

http://www.centos.org/modules/newbb/viewtopic.php?topic_id=14718&forum=8&post_id=51003#forumpost51003

Post Reply

Return to “CentOS 4 - Server Support”