Problem installing Prce

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
pjwelsh
Posts: 2610
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Problem installing Prce

Post by pjwelsh » 2008/07/14 19:11:36

If you have a sufficient build environment, you can run as root:
[code]rpmbuild --rebuild pcre-6.6-1.el4.remi.src.rpm[/code]
and look for (hope for) like that begin with "Wrote: /usr/src/redhat/RPMS/..."

If not, you need to figure out what build pieces you need. An *initial* shotgun approach would be to run:
[code]yum groupinstall "Development Tools"[/code]
as root. To get most of what you need.

cape
Posts: 14
Joined: 2007/06/05 20:04:00

Re: Problem installing Prce

Post by cape » 2008/07/14 20:45:13

rpm returns
rpmbuild --rebuild pcre-6.6-1.el4.remi.src.rpm
\Installing pcre-6.6-1.el4.remi.src.rpm
error: pcre-6.6-1.el4.remi.src.rpm cannot be installed

yum groupinstall "Development Tools"

[code]
-> Package xmlsec1-openssl.i386 0:1.2.6-3 set to be updated
---> Package symlinks.i386 0:1.2-22 set to be updated
---> Package perl-XML-Parser.i386 0:2.34-5 set to be updated
---> Package ibutils.i386 0:1.2-1 set to be updated
---> Package keyutils.i386 0:1.0-2 set to be updated
---> Package dosfstools.i386 0:2.8-18 set to be updated
---> Package unzip.i386 0:5.51-9.EL4.5 set to be updated
---> Package parted.i386 0:1.6.19-19.EL set to be updated
---> Package kernel-hugemem-devel.i686 0:2.6.9-67.0.20.plus.c4 set to be updated
---> Package numactl.i386 0:0.6.4-1.40 set to be updated
---> Package dmraid-devel.i386 0:1.0.0.rc14-6_RHEL4_U5 set to be updated
---> Package tcpdump.i386 14:3.8.2-12.el4_6.1 set to be updated
---> Package at.i386 0:3.1.8-80_EL4 set to be updated
---> Package gettext.i386 0:0.14.1-13 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-6_RHEL4_U5 set to be updated
---> Package automake14.noarch 0:1.4p6-12 set to be updated
---> Package splint.i386 0:3.1.1-4 set to be updated
---> Package libibverbs.i386 0:1.1.1-7 set to be updated
---> Package patchutils.i386 0:0.2.30-1 set to be updated
---> Package systemtap.i386 0:0.5.14-1 set to be updated
---> Package isdn4k-utils.i386 0:3.2-18.p1.1 set to be updated
---> Package iptstate.i386 0:1.3-4 set to be updated
---> Package perl-XML-Encoding.noarch 0:1.01-26 set to be updated
---> Package statserial.i386 0:1.1-35 set to be updated
---> Package rsh.i386 0:0.17-25.4 set to be updated
---> Package newt-devel.i386 0:0.51.6-9.rhel4 set to be updated
---> Package nfs-utils.i386 0:1.0.6-84.EL4 set to be updated
---> Package pcmcia-cs.i386 0:3.2.7-3.5 set to be updated
---> Package rcs.i386 0:5.7-26 set to be updated
---> Package slocate.i386 0:2.7-13.el4.8 set to be updated
---> Package utempter.i386 0:0.5.5-5 set to be updated
---> Package libuser-devel.i386 0:0.52.5-1.el4.1 set to be updated
---> Package ctags.i386 0:5.5.4-1 set to be updated
---> Package tcsh.i386 0:6.13-9.el4.1 set to be updated
---> Package perl-LDAP.noarch 0:0.31-5 set to be updated
---> Package mtr.i386 2:0.54-10 set to be updated
---> Package dialog.i386 0:1.0.20040731-3 set to be updated
---> Package swig.i386 0:1.3.21-6 set to be updated
---> Package dapl.i386 0:1.2.1.1-7 set to be updated
---> Package python-ldap.i386 0:2.0.1-2 set to be updated
---> Package lockdev-devel.i386 0:1.0.1-6.2 set to be updated
---> Package indent.i386 0:2.2.9-6 set to be updated
---> Package OpenIPMI.i386 0:1.4.14-1.4E.20 set to be updated
---> Package tog-pegasus-devel.i386 2:2.5.1-5.el4_6.1 set to be updated
---> Package finger.i386 0:0.17-26.EL4.1 set to be updated
---> Package stunnel.i386 0:4.05-3 set to be updated
---> Package sos.noarch 0:1.7-6.1.el4_6.2 set to be updated
---> Package pam_smb.i386 0:1.1.7-5 set to be updated
---> Package pciutils.i386 0:2.1.99.test8-3.4 set to be updated
---> Package nc.i386 0:1.10-22 set to be updated
---> Package pax.i386 0:3.0-9 set to be updated
---> Package dump.i386 0:0.4b39-3.EL4.2 set to be updated
---> Package ypbind.i386 3:1.17.2-13 set to be updated
---> Package acl.i386 0:2.2.23-5.3.el4 set to be updated
---> Package perl-XML-LibXML-Common.i386 0:0.13-7 set to be updated
---> Package libacl-devel.i386 0:2.2.23-5.3.el4 set to be updated
---> Package gcc-java.i386 0:3.4.6-9 set to be updated
---> Package jwhois.i386 0:3.2.2-6.EL4.1 set to be updated


---> Package python-devel.i386 0:2.3.4-14.4.el4_6.1 set to be updated
---> Package logrotate.i386 0:3.7.1-6.RHEL4 set to be updated
---> Package perl-Crypt-SSLeay.i386 0:0.51-5 set to be updated
---> Package psacct.i386 0:6.3.2-39.rhel4 set to be updated
---> Package kernel-devel.i686 0:2.6.9-67.0.20.plus.c4 set to be installed
---> Package grub.i386 0:0.95-3.8 set to be updated
---> Package mt-st.i386 0:0.8-1 set to be updated
---> Package pciutils-devel.i386 0:2.1.99.test8-3.4 set to be updated
---> Package libattr-devel.i386 0:2.4.16-3.1.el4 set to be updated
---> Package libvorbis-devel.i386 1:1.1.0-3.el4_6.1 set to be updated
---> Package cvs.i386 0:1.11.17-9.RHEL4 set to be updated
---> Package emacspeak.i386 0:17.0-7 set to be updated
---> Package byacc.i386 0:1.9-28 set to be updated
---> Package lksctp-tools.i386 0:1.0.2-6.4E.1 set to be updated
---> Package oprofile.i386 0:0.8.1-33 set to be updated
---> Package rdist.i386 1:6.1.5-38.40.2 set to be updated
--> Running transaction check
--> Processing Dependency: procmail for package: sendmail
--> Processing Dependency: libvorbis = 1:1.1.0 for package: libvorbis-devel
--> Processing Dependency: libusb = 0.1.8 for package: libusb-devel
--> Processing Dependency: libosmvendor.so.2(OSMVENDOR_2.0) for package: ibutils
--> Processing Dependency: libqt-mt.so.3 for package: oprofile
--> Processing Dependency: sgml-common for package: psgml
--> Processing Dependency: libkeyutils.so.1 for package: keyutils
--> Processing Dependency: usermode for package: system-config-network-tui
--> Processing Dependency: glib2-devel for package: dbus-devel
--> Processing Dependency: perl(Convert::ASN1) for package: perl-LDAP
--> Processing Dependency: openib for package: libibverbs
--> Processing Dependency: libgssapi for package: nfs-utils
--> Processing Dependency: krbafs = 1.2.2-6 for package: krbafs-devel
--> Processing Dependency: tk for package: ibutils
--> Processing Dependency: openib for package: dapl
--> Processing Dependency: syslinux for package: mkbootdisk
--> Processing Dependency: libgcj-devel >= 3.4.6 for package: gcc-java
--> Processing Dependency: libOpenIPMIutils.so.0 for package: OpenIPMI
--> Processing Dependency: libxmlsec1.so.1 for package: xmlsec1-openssl
--> Processing Dependency: bind-libs = 20:9.2.4-28.0.1.el4 for package: bind-utils
--> Processing Dependency: libOpenIPMI.so.0 for package: OpenIPMI
--> Processing Conflict: qmail conflicts sendmail
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: keyutils
--> Processing Dependency: nscd for package: nss_ldap
--> Processing Dependency: xmlsec1 = 1.2.6 for package: xmlsec1-openssl
--> Processing Dependency: libgcj >= 3.4.3 for package: java-1.4.2-gcj-compat
--> Processing Dependency: libosmcomp.so.1 for package: ibutils
--> Processing Dependency: usermode for package: kbd
--> Processing Dependency: libOpenIPMIglib.so.0 for package: OpenIPMI
--> Processing Dependency: yp-tools for package: ypbind
--> Processing Dependency: librdmacm.so.1 for package: dapl
--> Processing Dependency: htmlview for package: pinfo
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb
--> Processing Dependency: libwvstreams.so.3.75 for package: wvdial
--> Processing Dependency: usermode >= 1.36 for package: system-config-mouse
--> Processing Dependency: perl-Convert-ASN1 for package: perl-LDAP
--> Processing Dependency: rhpl >= 0.136 for package: system-config-mouse
--> Processing Dependency: rhnlib >= 1.8.7 for package: up2date
--> Processing Dependency: libopensm.so.1 for package: ibutils
--> Processing Dependency: gnupg for package: up2date
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb
--> Processing Dependency: mailx for package: redhat-lsb
--> Processing Dependency: libXaw3d.so.7 for package: emacs
--> Processing Dependency: libf2c = 3.4.6-9 for package: gcc-g77
--> Processing Dependency: fonts-xorg-75dpi for package: emacs
--> Processing Dependency: libdns.so.16 for package: bind-utils
--> Processing Dependency: libIPMIlanserv.so.0 for package: OpenIPMI
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.0) for package: keyutils
--> Processing Dependency: boost = 1.32.0-6.rhel4 for package: boost-devel
--> Processing Dependency: libgssapi.so.1 for package: nfs-utils
--> Processing Dependency: rmt for package: dump
--> Processing Dependency: libnfsidmap.so.0 for package: nfs-utils
--> Processing Dependency: lockdev = 1.0.1-6.2 for package: lockdev-devel
--> Processing Dependency: lockdev for package: minicom
--> Processing Dependency: libibcommon.so.1 for package: ibutils
--> Processing Dependency: openib for package: libmthca
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Processing Dependency: /usr/bin/tcl for package: emacspeak
--> Processing Dependency: libisc.so.7 for package: bind-utils
--> Processing Dependency: libOpenIPMIposix.so.0 for package: OpenIPMI
--> Processing Dependency: nfs-utils-lib for package: nfs-utils
--> Processing Dependency: perl(Data::Grove::Visitor) for package: perl-XML-Grove
--> Processing Dependency: libhesiod.so.0 for package: sendmail
--> Processing Dependency: libosmvendor.so.2 for package: ibutils
--> Processing Dependency: libibumad.so.1 for package: ibutils
--> Processing Dependency: libpcap >= 14:0.8.3-6 for package: ppp
--> Processing Dependency: libOpenIPMIcmdlang.so.0 for package: OpenIPMI
--> Processing Dependency: libqthreads.so.12 for package: swig
--> Processing Dependency: libguile-ltdl.so.1 for package: swig
--> Processing Dependency: libhesiod.so.0 for package: autofs
--> Processing Dependency: librdmacm.so.1(RDMACM_1.0) for package: dapl
--> Processing Dependency: liblwres.so.1 for package: bind-utils
--> Processing Dependency: libosmcomp.so.1(OSMCOMP_1.1) for package: ibutils
--> Processing Dependency: portmap >= 4.0 for package: nfs-utils
--> Processing Dependency: libibdmcom.so.1 for package: ibutils
--> Processing Dependency: hesiod = 3.0.2-30 for package: hesiod-devel
--> Processing Dependency: openib for package: libsdp
--> Processing Dependency: libpcap.so.0.8.3 for package: ppp
--> Processing Dependency: rhpl >= 0.81-2 for package: up2date
--> Processing Dependency: libungif.so.4 for package: emacs
--> Processing Dependency: systemtap-runtime = 0.5.14-1 for package: systemtap
--> Processing Dependency: libogg = 2:1.1.2 for package: libogg-devel
--> Processing Dependency: libOpenIPMIui.so.1 for package: OpenIPMI
--> Processing Dependency: libguile.so.12 for package: swig
--> Processing Dependency: libwvutils.so.3.75 for package: wvdial
--> Processing Dependency: mailx for package: logwatch
--> Processing Dependency: checkpolicy for package: setools
--> Processing Dependency: libusb-0.1.so.4 for package: bluez-utils
--> Processing Dependency: perl(Data::Grove) for package: perl-XML-Grove
--> Processing Dependency: libgcj >= 3.4.6 for package: gcc-java
--> Processing Dependency: libopensm.so.1(OPENSM_1.5) for package: ibutils
--> Processing Dependency: tog-pegasus >= 2.5.1 for package: tog-pegasus-devel
--> Processing Dependency: pyxf86config for package: system-config-mouse
--> Processing Dependency: rhpl >= 0:0.93.2 for package: system-config-network-tui
--> Processing Dependency: portmap for package: ypbind
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package rhnlib.noarch 0:2.1.1-9.el4_6 set to be updated
---> Package tk.i386 0:8.4.7-3.el4_6.1 set to be updated
---> Package nfs-utils-lib.i386 0:1.0.6-8.z1 set to be updated
---> Package tclx.i386 0:8.3.5-4 set to be updated
---> Package libgssapi.i386 0:0.8-1 set to be updated
---> Package libf2c.i386 0:3.4.6-9 set to be updated
---> Package openib.i386 0:1.2-7 set to be updated
---> Package htmlview.noarch 0:3.0.0-8 set to be updated
---> Package hesiod.i386 0:3.0.2-30 set to be updated
---> Package libungif.i386 0:4.1.3-1.el4.2 set to be updated
---> Package ibutils-libs.i386 0:1.2-1 set to be updated
---> Package xmlsec1.i386 0:1.2.6-3 set to be updated
---> Package libwvstreams.i386 0:3.75.0-2 set to be updated
---> Package OpenIPMI-libs.i386 0:1.4.14-1.4E.20 set to be updated
---> Package procmail.i386 0:3.22-14.1.el4 set to be updated
---> Package libibumad.i386 0:1.0.5-7 set to be updated
---> Package boost.i386 0:1.32.0-6.rhel4 set to be updated
---> Package nscd.i386 0:2.3.4-2.39 set to be updated
---> Package gnupg.i386 0:1.2.6-9 set to be updated
---> Package opensm-libs.i386 0:3.0.3-7 set to be updated
---> Package usermode.i386 0:1.74-2 set to be updated
---> Package rhpl.i386 0:0.148.6-1 set to be updated
---> Package checkpolicy.i386 0:1.17.5-1 set to be updated
---> Package qt.i386 1:3.3.3-13.RHEL4 set to be updated
---> Package mailx.i386 0:8.1.1-37.EL4 set to be updated
---> Package libgcj-devel.i386 0:3.4.6-9 set to be updated
---> Package perl-Convert-ASN1.noarch 0:0.18-3 set to be updated
---> Package perl-libxml-perl.noarch 0:0.07-30 set to be updated
---> Package rmt.i386 0:0.4b39-3.EL4.2 set to be updated
---> Package fonts-xorg-75dpi.noarch 0:6.8.2-1.EL set to be updated
---> Package cups.i386 1:1.1.22-0.rc1.9.20.2.el4_6.8 set to be updated
---> Package libgcj.i386 0:3.4.6-9 set to be updated
---> Package glib2-devel.i386 0:2.4.7-1 set to be updated
---> Package bind-libs.i386 20:9.2.4-28.0.1.el4 set to be updated
---> Package guile.i386 5:1.6.4-14 set to be updated
---> Package libpcap.i386 14:0.8.3-12.el4_6.1 set to be updated
---> Package pyxf86config.i386 0:0.3.19-1 set to be updated
---> Package librdmacm.i386 0:1.0.1-7 set to be updated
---> Package keyutils-libs.i386 0:1.0-2 set to be updated
---> Package yp-tools.i386 0:2.8-7 set to be updated
---> Package portmap.i386 0:4.0-63 set to be updated
---> Package systemtap-runtime.i386 0:0.5.14-1 set to be updated
---> Package syslinux.i386 0:2.11-1 set to be updated
---> Package lockdev.i386 0:1.0.1-6.2 set to be updated
---> Package libogg.i386 2:1.1.2-1 set to be updated
---> Package sgml-common.noarch 0:0.6.3-17 set to be updated
---> Package Xaw3d.i386 0:1.5-24 set to be updated
---> Package tog-pegasus.i386 2:2.5.1-5.el4_6.1 set to be updated
---> Package libibcommon.i386 0:1.0.3-7 set to be updated
---> Package libvorbis.i386 1:1.1.0-3.el4_6.1 set to be updated
---> Package krbafs.i386 0:1.2.2-6 set to be updated
---> Package libusb.i386 0:0.1.8-3 set to be updated
--> Running transaction check
--> Processing Dependency: libcups.so.2 for package: cups
--> Processing Dependency: libgdk-x11-2.0.so.0 for package: libgcj
--> Processing Dependency: libcupsimage.so.2 for package: cups
--> Processing Dependency: xinetd for package: cups
--> Processing Dependency: libatk-1.0.so.0 for package: libgcj
--> Processing Dependency: cups-libs = 1:1.1.22 for package: cups
--> Processing Dependency: /usr/X11R6/bin/mkfontdir for package: fonts-xorg-75dpi
--> Processing Dependency: umb-scheme >= 3.2-21 for package: guile
--> Processing Conflict: qmail conflicts sendmail
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: libgcj
--> Processing Dependency: redhat-menus >= 1.11 for package: htmlview
--> Processing Dependency: pyOpenSSL for package: rhnlib
--> Processing Dependency: libpango-1.0.so.0 for package: libgcj
--> Processing Dependency: chkfontpath for package: fonts-xorg-75dpi
--> Processing Dependency: libpangoxft-1.0.so.0 for package: libgcj
--> Processing Dependency: libgtk-x11-2.0.so.0 for package: libgcj
--> Processing Dependency: libpangox-1.0.so.0 for package: libgcj
--> Processing Dependency: gtk2 >= 2.4.0 for package: libgcj
--> Processing Dependency: libmng.so.1 for package: qt
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package redhat-menus.noarch 0:3.7.1-2 set to be updated
---> Package umb-scheme.i386 0:3.2-36.EL4 set to be updated
---> Package gtk2.i386 0:2.4.13-22 set to be updated
---> Package atk.i386 0:1.8.0-2 set to be updated
---> Package pyOpenSSL.i386 0:0.6-1.p23 set to be updated
---> Package xinetd.i386 2:2.3.13-4.4E.1 set to be updated
---> Package libmng.i386 0:1.0.8-1 set to be updated
---> Package pango.i386 0:1.6.0-9 set to be updated
---> Package chkfontpath.i386 0:1.10.0-2 set to be updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.9.20.2.el4_6.8 set to be updated
---> Package xorg-x11-font-utils.i386 0:6.8.2-1.EL.33.0.4 set to be updated
--> Running transaction check
--> Processing Dependency: desktop-file-utils >= 0.9 for package: redhat-menus
--> Processing Dependency: xfs for package: chkfontpath
--> Processing Conflict: qmail conflicts sendmail
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-xfs.i386 0:6.8.2-1.EL.33.0.4 set to be updated
---> Package desktop-file-utils.i386 0:0.9-3.el4 set to be updated
--> Running transaction check
--> Processing Dependency: /usr/bin/ttmkfdir for package: xorg-x11-xfs
--> Processing Dependency: base-fonts for package: xorg-x11-xfs
--> Processing Conflict: qmail conflicts sendmail
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package fonts-xorg-base.noarch 0:6.8.2-1.EL set to be updated
---> Package ttmkfdir.i386 0:3.0.9-20.el4 set to be updated
--> Running transaction check
--> Processing Conflict: qmail conflicts sendmail
--> Finished Dependency Resolution
Error: qmail conflicts with sendmail
[/code]

Post Reply

Return to “CentOS 4 - Server Support”