Configure php with pear

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
maxime
Posts: 25
Joined: 2005/11/10 08:04:38

Configure php with pear

Post by maxime » 2008/03/20 07:28:19

Hello,

I've php5 installed on my Centos box. Pear is installed too, but php is configured without pear :(
[quote]yum list installed *php*
Installed Packages
php.i386 5.1.6-3.el4s1.8 installed
php-cli.i386 5.1.6-3.el4s1.8 installed
php-common.i386 5.1.6-3.el4s1.8 installed
php-gd.i386 5.1.6-3.el4s1.8 installed
php-mysql.i386 5.1.6-3.el4s1.8 installed
php-pdo.i386 5.1.6-3.el4s1.8 installed
php-pear.noarch 1:1.4.11-1.el4s1.1 installed[/quote]

I read documentation, and i should use ./configure in order to recompile php with pear, but i didn't find such as configure file into Centos.
How can i configure php with pear ?

Thanks for help.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Configure php with pear

Post by gerald_clark » 2008/03/20 13:31:20

CentOS 4 comes with PHP4 not PHP5.
Did you get your php-pear from the same place you got your PHP?

maxime
Posts: 25
Joined: 2005/11/10 08:04:38

Re: Configure php with pear

Post by maxime » 2008/03/20 14:37:13

Maybe i didn't update pear when i updated php.
I tried this : yum --enablerepo centosplus update php-pear and yum --enablerepo centosplus upgrade php-pear
But i got this :

[quote]Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for php-pear
No Packages marked for Update/Obsoletion[/quote]

Any suggest ?
Thanks

User avatar
toracat
Forum Moderator
Posts: 7434
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Configure php with pear

Post by toracat » 2008/03/20 15:20:59

As far as I can tell, your files are all up-to-date. Why do you think php is not configured with pear?

maxime
Posts: 25
Joined: 2005/11/10 08:04:38

Re: Configure php with pear

Post by maxime » 2008/03/20 15:42:44

Because i saw that in phpinfo() :

[code]Configure Command './configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'[/code]

--> without pear

Post Reply

Return to “CentOS 4 - Server Support”