Spamassassin's sa-update and the regularity of updates

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
oliau
Posts: 13
Joined: 2006/06/29 02:35:20
Location: Australia
Contact:

Spamassassin's sa-update and the regularity of updates

Post by oliau » 2008/03/20 06:30:01

How often are the spamassassin rules available to download with sa-update actually updated? When I run it and look in the directory where the [url=http://wiki.apache.org/spamassassin/RuleUpdates]sa-update[/url] page says the rules will be placed it shows files that have not been changed since March the 2nd. On the same page it says you can run it once a day to keep on top of updates. Am I missing something here or are there just periods sometimes where rules aren't updated all that regularly?

Thanks in advance. :)

kentyler
Posts: 161
Joined: 2007/06/20 13:31:05
Location: Northeast Ohio
Contact:

Re: Spamassassin's sa-update and the regularity of updates

Post by kentyler » 2008/04/18 20:17:41

You might try adding the file /etc/cron.d/sa-update if it does not exsist


### OPTIONAL: Spamassassin Rules Updates ###
#
# http://wiki.apache.org/spamassassin/RuleUpdates g # Highly recommended that you read the documentation before using this.
# ENABLE UPDATES AT YOUR OWN RISK.
#
# /var/log/sa-update.log contains a history log of sa-update runs

10 4 * * * root /usr/bin/sa-update 2>&1 | tee -a /var/log/sa-update.log


try sa-update -D

[root@smtp2 cron.d]# /usr/bin/sa-update -D
[29570] dbg: logger: adding facilities: all
[29570] dbg: logger: logging level is DBG
[29570] dbg: generic: SpamAssassin version 3.2.4
[29570] dbg: config: score set 0 chosen.
[29570] dbg: dns: no ipv6
[29570] dbg: dns: is Net::DNS::Resolver available? yes
[29570] dbg: dns: Net::DNS version: 0.62
[29570] dbg: generic: sa-update version svn607589
[29570] dbg: generic: using update directory: /var/lib/spamassassin/3.002004
[29570] dbg: diag: perl platform: 5.008008 linux
[29570] dbg: diag: module installed: Digest::SHA1, version 2.11
[29570] dbg: diag: module installed: HTML::Parser, version 3.56
[29570] dbg: diag: module installed: Net::DNS, version 0.62
[29570] dbg: diag: module installed: MIME::Base64, version 3.07
[29570] dbg: diag: module installed: DB_File, version 1.814
[29570] dbg: diag: module installed: Net::SMTP, version 2.31
[29570] dbg: diag: module installed: Mail::SPF, version v2.005
[29570] dbg: diag: module installed: Mail::SPF::Query, version 1.999001
[29570] dbg: diag: module installed: IP::Country::Fast, version 604.001
[29570] dbg: diag: module not installed: Razor2::Client::Agent ('require' failed)
[29570] dbg: diag: module installed: Net::Ident, version 1.20
[29570] dbg: diag: module installed: IO::Socket::INET6, version 2.51
[29570] dbg: diag: module installed: IO::Socket::SSL, version 1.01
[29570] dbg: diag: module installed: Compress::Zlib, version 2.008
[29570] dbg: diag: module installed: Time::HiRes, version 1.9711
[29570] dbg: diag: module installed: Mail::DomainKeys, version 1.0
[29570] dbg: diag: module installed: Mail::DKIM, version 0.301
[29570] dbg: diag: module installed: DBI, version 1.601
[29570] dbg: diag: module installed: Getopt::Long, version 2.35
[29570] dbg: diag: module installed: LWP::UserAgent, version 2.033
[29570] dbg: diag: module installed: HTTP::Date, version 1.47
[29570] dbg: diag: module installed: Archive::Tar, version 1.38
[29570] dbg: diag: module installed: IO::Zlib, version 1.09
[29570] dbg: diag: module installed: Encode::Detect, version 1.00
[29570] dbg: gpg: Searching for 'gpg'
[29570] dbg: util: current PATH is: /usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
[29570] dbg: util: executable for gpg was found at /usr/bin/gpg
[29570] dbg: gpg: found /usr/bin/gpg
[29570] dbg: gpg: release trusted key id list: 5E541DC959CB8BAC7C78DFDC4056A61A5244EC45 26C900A46DD40CD5AD24F6D7DEE01987265FA05B 0C2B1D7175B852C64B3CDC716C55397824F434CE
[29570] dbg: channel: attempting channel updates.spamassassin.org
[29570] dbg: channel: update directory /var/lib/spamassassin/3.002004/updates_spamassassin_org
[29570] dbg: channel: channel cf file /var/lib/spamassassin/3.002004/updates_spamassassin_org.cf
[29570] dbg: channel: channel pre file /var/lib/spamassassin/3.002004/updates_spamassassin_org.pre
[29570] dbg: channel: metadata version = 648641
[29570] dbg: dns: 4.2.3.updates.spamassassin.org => 648641, parsed as 648641
[29570] dbg: channel: current version is 648641, new version is 648641, skipping channel
[29570] dbg: diag: updates complete, exiting with code 1

Post Reply

Return to “CentOS 4 - Server Support”