Centos 4.4 sendmail smtp-auth for smart host

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
safusa
Posts: 2
Joined: 2005/02/15 18:12:20
Location: Baton Rouge LA
Contact:

Centos 4.4 sendmail smtp-auth for smart host

Post by safusa » 2007/02/23 22:09:40

I have configured several machines to use the smart host feature of sendmail. I have my current machine centos 4.4 setup exactly like I have done on my previous 3.8 machines which work.

Every time I try to send an email the following appears in the log.
[i]
Feb 23 15:26:39 localhost sendmail[9722]: STARTTLS=client, relay=smtpauth.earthlink.net., version=TLSv1/SSLv3, verify=FAIL, cipher=AES256-SHA, bits=256/256
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libsasldb.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libplain.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libgssapiv2.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libcrammd5.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libsql.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libanonymous.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/liblogin.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libntlm.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: error: safesasl(/usr/lib/sasl2/libdigestmd5.so.2) failed: World writable directory
Feb 23 15:26:39 localhost sendmail[9722]: l1NLQcLR009720: AUTH=client, available mechanisms do not fulfill requirements
Feb 23 15:26:39 localhost sendmail[9722]: AUTH=client, relay=smtpauth.earthlink.net., temporary failure, connection abort
Feb 23 15:26:39 localhost sendmail[9722]: l1NLQcLR009720: to=, tladdr= (0/0), delay=00:00:01, xdelay=00:0
0:00, mailer=relay, pri=122002, relay=smtpauth.earthlink.net. [207.69.189.202],dsn=4.0.0, stat=Deferred: Temporary AUTH failure
[/i]

Here are the some of the lines from my sendmail.mc
[i]
define(`SMART_HOST',`smtpauth.earthlink.net')
define(`confAUTH_OPTIONS', `A')dnl
TRUST_AUTH_MECH(`LOGIN PLAIN')dnl
define(`confAUTH_MECHANISMS', `LOGIN PLAIN')dnl
FEATURE(`authinfo',`hash /etc/mail/auth/authinfo')dnl
[/i]

authinfo.db has permissions of 600, auth folder has permissions of 600
and contains
[i]Authinfo:smtpauth.earthlink.net "U:user@earthlink.net" "I:user@earthlink.net" "P:password" "M:PLAIN LOGIN" [/i]

Earthlink offers login plain starttls, I have verified the login information using a windows client, tested with and with out TLS.

Any help or suggestions would be greatly appreciated. Just to make sure it wasn't an issue on one machine, I tried setting the same information up on another centos 4.4 box with the same results.

Thanks

mariano
Posts: 37
Joined: 2006/02/14 19:45:02
Location: Cordoba, Argentina
Contact:

Re: Centos 4.4 sendmail smtp-auth for smart host

Post by mariano » 2008/09/17 05:38:16

I know a little time has passed but can you comment if you find out how to resolve this issue? I'm stuck in the same place right now.

safusa
Posts: 2
Joined: 2005/02/15 18:12:20
Location: Baton Rouge LA
Contact:

Re: Centos 4.4 sendmail smtp-auth for smart host

Post by safusa » 2008/09/17 12:40:18

It ended up being a permission problem on /usr, some where along the way the permissions on /usr had gotten changed. I don't remember what the permissions were suppose to be but once I change it back to that it worked perfectly.

I think the permissions ended up getting changed when I had restored a tar backup of some files.

I looked at a fresh install to see what the permissions should be then reset them.

Post Reply

Return to “CentOS 4 - Server Support”