Trouble installing Bind via Yum

Installing, Configuring, Troubleshooting server daemons such as Web and Mail
Post Reply
Posts: 3
Joined: 2006/12/26 10:37:15

Trouble installing Bind via Yum

Post by jibber » 2006/12/26 10:48:57

Hi Everyone,

I'm having trouble installing a DNS server on my Centos Box.

As per instructions I've found I issue the command "yum install bind"
It seems to go well until it tries to install files to /usr/sbin where it give an error`"Permision Denied"

I've tried to create another file and save it but get the same message. I assumed a permission problem but it still get the same problem when I log in as root from the console.

Does anyone have any suggestions?

Thanks in advance

Site Admin
Posts: 875
Joined: 2005/01/03 21:30:54
Location: /country/belgium

Trouble installing Bind via Yum

Post by arrfab » 2006/12/26 16:44:33

It seems your permissions are not (anymore) good ... /usr/sbin should be 755 and owned by root.root

Posts: 3
Joined: 2006/12/26 10:37:15

Re: Trouble installing Bind via Yum

Post by jibber » 2006/12/29 10:33:06

Thanks for your reply,

I've checked the permissions for /usr/sbin

[quote]drwxr-xr-x 3 root root 12288 Jun 19 2006 sbin
drwxrwxrwx 100 root root 4096 Jun 18 2006 share
drwxrwxrwx 23 root root 4096 May 27 2006 src
lrwxrwxrwx 1 root root 10 May 27 2006 tmp -> ../var/tmp
[root@server usr]# whoami

When it try to install bin with YUM i get the following output.

[root@server usr]# yum install bind
Setting up Install Process
Setting up repositories
Transaction Test Succeeded
Running Transaction
Installing: bind [1/1]warning: /etc/logrotate.d/named created as /etc/logrotate.d/named.rpmnew
Installing: bind [1/1]warning: /etc/rc.d/init.d/named saved as /etc/rc.d/init.d/named.rpmorig
Installing: bind [1/1]warning: /etc/rndc.conf created as /etc/rndc.conf.rpmnew
Installing: bind [1/1]warning: /etc/rndc.key created as /etc/rndc.key.rpmnew
Installing: bind [1/1]warning: /etc/sysconfig/named created as /etc/sysconfig/named.rpmnew
Installing: bind ######################### [1/1]
error: unpacking of archive failed on file /usr/sbin/dns-keygen;4594ed89: cpio: open

Installed: bind.i386 20:9.2.4-16.EL4


Can anyone seem the problem. I've been trying to fix this for weeks.

Thanks again

Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: Trouble installing Bind via Yum

Post by foxb » 2006/12/29 14:52:00

Is SELinux enabled?

What is the result of

rpm -q bind ?

Posts: 3
Joined: 2006/12/26 10:37:15

Re: Trouble installing Bind via Yum

Post by jibber » 2007/01/01 06:12:53

To my knowledge SELinux is not installed - Can you tell me how to check if it is installed.

rpm -q bind - package bind is not installed.

Posts: 1
Joined: 2009/12/08 08:43:33

Re: Trouble installing Bind via Yum

Post by hueoogle » 2009/12/08 09:00:28

To the best of my knoweledge, bind9 or or either centos (either or) ~whatever seems to like running in CHROOT jail. If you are not farmiliar with this its a pretty simple concept. It actually runs out of /var/named/chroot/var/named/...

My point is when I install bind on any 'newer' system like bind9 on centos 5+ or the like as I was trying to elaborate above, I use this:

[code]# yum install bind-chroot[/code]

and it works like a charm every time for me, using centos 5.2. Of course, then, named.conf is also then no longer located in /etc/named.conf either. In fact, it doesn't even create one. So I would really suggest taking it one step at a time and getting your local view, then internal view, then external view working all tested first before moving to the next step. Looking at the logs, trouble shooting and what not to help out what might be the problem. I would be happy to send you a copy of my named.conf.

Be warned though, there has been much improvements. I have seen posts where a senior member swore to the death that you HAVE to add your ISP dns servers to your /etc/resolv.conf or it won't work, but if you set it up correctly, then the localhost authoritive nameserver for your domain should then go up and out to find the answer (i.e. ping and come back fine.

I wanted to throw that bit in there after seeing that post as you should only have your domain i.e.


But bind/named whatever will not let you out (resolv any other hosts like google or yahoo or ANYTHING) if you don't have your named.conf setup correctly. Mine has finally got working like a charm. BTW, i stated it doesn't run in /etc/named.conf when you install how I stated, If you run

# service named start

It should give you an error about where it cannot find the named.conf, and then you will know exactly where its looking for it, of course. Post be back if you need help. I have spent quite a bit of time with DNS servers. FUN FUN!

Post Reply

Return to “CentOS 4 - Server Support”