Puzzling issue: no network connection on CentOS 4.8 but eth0 looks fine!

Issues related to configuring your network
Post Reply
Posts: 6
Joined: 2012/02/21 17:19:32

Puzzling issue: no network connection on CentOS 4.8 but eth0 looks fine!

Post by suaswe » 2012/02/21 17:28:49

Hi all,

First time posting and only just started using CentOS, so please bear with me! The idea was to regrade my old trusty "server" (an old Packard Bell laptop) from Ubuntu Server 8.04 to CentOS for increased familiarity with Red Hat-like systems. Having looked round for system requirements for CentOS 5 and 6, I determined that 4 (4.8 specifically) may be the most viable option. Before I go any further, if anyone could advise on a better option for a 1.2GHz 512MB RAM laptop with integrated graphics, I'd appreciate it! The surer I am the better as I've already gone through quite a few blank DVD's trying to find a system it will work with. ;)

Anyway: the install itself went OK-ish; I had to set boot option to 'linux nofb' to avoid getting a frozen blank screen but once I'd done that it went through OK. I have attempted the installation twice, once using my own ideas of partitioning and customised setup, and then when this failed as I am shortly to describe I tried for the automatic partitioning and default server setup, with the same result.

So, to the problem: whilst eth0 is showing as "up" in ifconfig and ethtool, and is configured with known correct settings (used on previous server install and later tested on Ubuntu LiveCD just in case), I am not getting a connection to my router, and as a result not to anything else either.

I have attached the outputs of the commands and file outputs I thought might be useful to diagnose the problem, namely:

ethtool eth0
ifconfig -a
/etc/init.d/network restart # produces 'irc 201' errors but restarts fine
ps -ef

To sum up briefly, my desired static IP config is:


And what I have for eth0 on ifconfig, ethtool, /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network are:

# ifconfig output
eth0 Link encap:Ethernet HWaddr MA:CM:AC:MA:CM:AC
inet addr: Bcast: Mask:
inet6 addr: fe80::216:36ff:fe92:cdcd/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:120 (120.0 b)
Interrupt:201 Base address:0xa000

# ethtool output
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000007 (7)
Link detected: yes

# /etc/sysconfig/network-scripts/ifcfg-eth0

# /etc/sysconfig/network

I tried disconnecting the ethernet cable and link detection switched to "no" then back to "yes" once reconnected, suggesting the physical link is OK - also confirmed this by connecting via eth0 with the same static settings via a Ubuntu LiveCD.

Basically, as far as I can tell there are no issues with config, but I am still getting this:

user@suaserve ~]$ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Desination Host Unreachable
From icmp_seq=2 Desination Host Unreachable
From icmp_seq=3 Desination Host Unreachable

--- ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2998ms, pipe4

At this point I'm assuming that one of two causes is true:

1. I am missing something glaringly obvious, maybe something that is running but shouldn't or vice versa
2. My server isn't happy with this kernel

Much Googling has not got me closer to a solution - any advice would be much appreciated! On a related note: I keep seeing suggestions that people upgrade their kernel; would this be worth doing and if so how would I go about it without an internet connection?

Edit: the file attachment failed - if required I have also attached it to the Ubuntu forum post on the same topic (http://ubuntuforums.org/showthread.php?t=1928825).

Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Puzzling issue: no network connection on CentOS 4.8 but eth0

Post by gerald_clark » 2012/02/21 17:38:04

Welcome to CentOS.

New users need to read:

CentOS 4 will be End Of life in just a few days.
You would be better off with CentOS 5 or Centos 6.

Looks like a bad cable or switch to me.

Posts: 6
Joined: 2012/02/21 17:19:32

Re: Puzzling issue: no network connection on CentOS 4.8 but eth0 looks fine!

Post by suaswe » 2012/02/21 20:10:28

Hi there,

Thanks for your reply, much appreciated! As above both router, cable and NIC have been confirmed as healthy by connecting with the same settings on Ubuntu LiveCD in between the two installation attempts as well as after. I'm beginning to lean toward kernel trouble personally - am actually planning to upgrade the hardware this week, allowing me to use CentOS 5 or 6 (neither of which will install on this laptop) so maybe it's just time for my poor old Packard to be shelved. :D

Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America

Re: Puzzling issue: no network connection on CentOS 4.8 but eth0 looks fine!

Post by pschaff » 2012/02/22 01:19:02

If you want to proceed then please [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=28723&forum=54]provide more information about your system[/url] by running "./getinfo.sh" and showing us the output file.

CentOS 5 may be worth a try. With CentOS-6 you could only attempt a minimal text-mode install with that amount of memory, and explained in the [url=http://wiki.centos.org/Manuals/ReleaseNotes/CentOS6.2]CentOS 6.2 Release Notes[/url].

Post Reply

Return to “CentOS 4 - Networking Support”