Unable to connect to the Internet using centos

Issues related to configuring your network
Post Reply
abhishek77
Posts: 6
Joined: 2008/02/06 21:26:26

Unable to connect to the Internet using centos

Post by abhishek77 » 2008/08/01 16:38:02

I have just setup a wireless router and it works fine with windows vista. I am running centos on a laptop as well as on another hard drive within the same system running windows vista.

I need to know how to configure the settings within centos to connect to the internet.
I have tried entering ip, subnet mask and gateway but no luck so far.

Even prior to setting up this router, i was unable to connect to the internet using centos but at that time did not bother much about this issue.
However in the past when i used fedora, i never experienced any such issues as it used to determine the etho settings automatically.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Unable to connect to the Internet using centos

Post by gerald_clark » 2008/08/01 16:58:30

Can you ping your other local machines?
What are the output of:
ifconfig
iwconfig
route -n
cat /etc/resolv.conf

abhishek77
Posts: 6
Joined: 2008/02/06 21:26:26

Re: Unable to connect to the Internet using centos

Post by abhishek77 » 2008/08/02 19:54:41

Here is the output.

[root@localhost ~]# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1760 errors:0 dropped:0 overruns:0 frame:0
TX packets:1760 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1518520 (1.4 MiB) TX bytes:1518520 (1.4 MiB)

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

[root@localhost ~]# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
cat: etc/resolv.conf: No such file or directory
[root@localhost ~]# cat /etc/resolv.conf
[root@localhost ~]#

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: Unable to connect to the Internet using centos

Post by gerald_clark » 2008/08/04 18:03:16

Your wireless card was not found.
What is the output of 'lspci'?
Maybe someone with your card can help.

Post Reply

Return to “CentOS 4 - Networking Support”