Real basic networking-file sharing issue

Issues related to configuring your network
Post Reply
Posts: 3
Joined: 2008/04/21 21:18:50

Real basic networking-file sharing issue

Post by srfii » 2008/04/21 22:26:57

Hello all,
I am a complete linux newbie, and just installed my first linux OS (Centos) this weekend. Had some fun getting drivers and stuff installed for the ethernet card (still need to install my 4965 wireless drivers). Now that I have internet and network connectivity, I tried my hand at getting my linux machine to see my windows server. The problem I have is two fold, but for now I want to focus on on the first.

My linux machine can find the files and folders on the windows server just fine, and as long as the file names are appropriate can open or copy them over. However, any of my folders or files with a space in the name shows up as a %20 symbol by my linux box which then refuses to open the folder or file because the content is deemed unknown (it says I should rename the files if I trust them).

I have installed both samba client and server (SWAT) services though right now I am only running the client. My smb.conf is as follows (from testparm):

workgroup = SRFWORK_LAN #thats my workgroup
server string = Samba Server Version%
passdb backend = tdbsam
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
cups options = raw

comment = Home Directories
read only = no
browseable = no

comment = public staff
path = /home/samba
write list = +staff
read only = no
guest ok = yes

Now I think I have that configured correctly. Something I am struggling with is because of the space character giving me the problems and other files names sharing just fine, I thought I might have a protocol issue. everything is accessed as "smb://".
At first I thought this meant samba as I know the client service is running, but on one of the forums I found out that GNOME has some default protocol it uses that runs as smb:// to access drives and that its pretty crappy. So I guess I am wondering now that even if I am running samba that my folder browsers are not using it in CentOS. But I can't figure out how to actually map to the drives in the terminal window using samba.

Also, somewhere I found a comment that my network should be mounted as a drive, but I had issues in trying that and am still unsure if that is the issue, or even if I mount it, will it use samba or this same smb protocol (assuming that is the problem).

Any suggestions, help, or better yet solutions, will be greatly appreciated!!


PS: one more simple item if anyone wants to help.
My windows machines can see my linux box as a samba server, but upon accessing it, a password is linux username and password are not accepted. Is there a different user/password setup for samba?

Posts: 3
Joined: 2008/04/21 21:18:50

UPDATE: Real basic networking-file sharing issue

Post by srfii » 2008/04/21 22:59:46

Figures that right after I post this I would have found a partial solution.

I was able to mount my windows server folders in such a way using 'smbmount' that I can now, filenames with spaces appear correctly and I can access them.

However, to get to them I have to cd into the mounted location: /mnt/samba/Athens

What I really want is to get the drives to appear in the file-browser, but when I use the file browser in CentOS, I still can only navigate to the windows network, see all the computers but still not explore the now I need to figure out how to mount the server drives in such a way that the files browser can see them. Thank you for any help.

Post Reply

Return to “CentOS 4 - Networking Support”