Bonding Intel 82546GB dual port: Errors

Issues related to configuring your network
Post Reply
midair77
Posts: 19
Joined: 2006/10/03 19:04:39

Bonding Intel 82546GB dual port: Errors

Post by midair77 » 2007/06/28 00:21:10

Hi, all. I am trying to set up Ethernet bonding for an Intel dual port Gigabit card but for some reasons I got these messages in the dmesg.

1. Edit /etc/modprobe.conf
alias bond0 bonding
options bond0 mode=0 miimon=100

alias eth2 e1000
alias eth3 e1000

2. modprobe bond0
3. ifconfig bond0 10.0.1.251 netmask 255.x.x.x broadcast 10.0.1.255 up
4. ifenslave bond0 eth2 eth3

Here is what I found in dmesg. I also tested to ping this interface on the same node and found out that it is up. From other nodes on the same switch, I was able to ssh to that node using 10.0.1.251.

What are possible problems here?
dmesg
*****
Ethernet Channel Bonding Driver: v3.1.1 (September 26, 2006)
bonding: MII link monitoring set to 100 ms
ADDRCONF(NETDEV_UP): bond0: link is not ready
ADDRCONF(NETDEV_UP): eth2: link is not ready
bonding: bond0: enslaving eth2 as an active interface with a down link.
ADDRCONF(NETDEV_UP): eth3: link is not ready
bonding: bond0: enslaving eth3 as an active interface with a down link.
e1000: eth2: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
bonding: bond0: link status definitely up for interface eth2.
ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready

=================================
[ INFO: inconsistent lock state ]
2.6.19.2 #1
---------------------------------
inconsistent {softirq-on-R} -> {in-softirq-W} usage.
swapper/0 [HC0[0]:SC1[2]:HE1:SE0] takes:
(&bond->curr_slave_lock){.+-?}, at: [] bond_xmit_roundrobin+0xac/0xdd [bonding]
{softirq-on-R} state was registered at:
[] __lock_acquire+0x4db/0xb15
[] lock_acquire+0x57/0x70
[] 0xffffffffffffffff
irq event stamp: 1737660928
hardirqs last enabled at (1737660928): [] local_bh_enable+0x159/0x15d
hardirqs last disabled at (1737660927): [] local_bh_enable+0xce/0x15d
softirqs last enabled at (1737660892): [] call_softirq+0x1c/0x30
softirqs last disabled at (1737660895): [] call_softirq+0x1c/0x30

other info that might help us debug this:
1 lock held by swapper/0:
#0: (&bond->lock){-.-+}, at: [] bond_xmit_roundrobin+0x1b/0xdd [bonding]

stack backtrace:

Call Trace:
[] show_trace+0x34/0x47
[] dump_stack+0xe/0x11
[]

e1000: eth3: e1000_watchdog: NIC Link is Up 1000 Mbps Full Duplex
bonding: bond0: link status definitely up for interface eth3.
ADDRCONF(NETDEV_CHANGE): eth3: link becomes ready

Thank you.

Post Reply

Return to “CentOS 4 - Networking Support”