No Internet Connectivity on CentOS 4.4 Final

Issues related to configuring your network
Post Reply
bullium
Posts: 3
Joined: 2007/05/17 13:03:20
Contact:

No Internet Connectivity on CentOS 4.4 Final

Post by bullium » 2007/05/17 13:09:47

I'm Running CentOS release 4.4 (Final) on an HP DL360 Server with two NIC cards. I currently cannot communicate with anything outside the local network. I can ping and connect to all devices on the internal network including other devices on other internal networks. This means the router is routing traffic for this host. All other hosts on the network can communicate with the internet. This box and all others on the network are configured to use a local DNS server. This box is resolving domain names to IP address. I can ping the router and the firewall connected to the internet and vice versa, therefore all local communication is good. I found this thread http://www.linuxquestions.org/questi...ss#post2550959 where someone was running into the same problem on this release. Their solution was a reinstall, which is not an option for me. Therefore I’m starting a new thread in hopes of some help finding a solution to this problem. The system has two NICs. eth0 is being used and eth1 is disabled and not used.

This is the topology of how this box is connected to the network/internet.

-------------------------------------------------------------------------------------------------------------
centosbox -> 2950switch -> 4000router -> PIXfirewall -> Internet
-------------------------------------------------------------------------------------------------------------

Output from some config files as well as commands.

[code]
cat /etc/sysconfig/network
[/code]

NETWORKING=yes
HOSTNAME=centosbox.localhost
GATEWAY=192.168.20.252
-------------------------------------------------------------------------------------------------------------

[code]
cat /etc/sysconfig/network-scripts/ifcfg-eth0
[/code]
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.20.218
NETMASK=255.255.255.0
-------------------------------------------------------------------------------------------------------------

[code]
cat /etc/sysconfig/network-scripts/ifcfg-eth1
[/code]
DEVICE=eth1
ONBOOT=no
BOOTPROTO=dhcp

-------------------------------------------------------------------------------------------------------------
[code]
cat /etc/resolv.conf
[/code]
nameserver 192.168.20.226
-------------------------------------------------------------------------------------------------------------
[code]
ifconfig eth0
[/code]
eth0 Link encap:Ethernet HWaddr 00:19:BB:38:F0:BA
inet addr:192.168.20.218 Bcast:192.168.20.255 Mask:255.255.255.0
inet6 addr: fe80::219:bbff:fe38:f0ba/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:984537 errors:0 dropped:0 overruns:0 frame:0
TX packets:203954 errors:365 dropped:0 overruns:0 carrier:365
collisions:422 txqueuelen:1000
RX bytes:114990204 (109.6 MiB) TX bytes:65373057 (62.3 MiB)
Interrupt:10 Memory:f8000000-f8011100

-------------------------------------------------------------------------------------------------------------

[code]
route
[/code]
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.20.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.20.252 0.0.0.0 UG 0 0 0 eth0
-------------------------------------------------------------------------------------------------------------

Any help would be appreciated, thanks.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: No Internet Connectivity on CentOS 4.4 Final

Post by gerald_clark » 2007/05/17 13:40:05

What does

traceroute ebay.com

show?

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: No Internet Connectivity on CentOS 4.4 Final

Post by foxb » 2007/05/17 13:47:04

Can you ping .252?

bullium
Posts: 3
Joined: 2007/05/17 13:03:20
Contact:

Re: No Internet Connectivity on CentOS 4.4 Final

Post by bullium » 2007/05/17 14:23:26

[quote]
gerald_clark wrote:
What does

traceroute ebay.com

show?[/quote]

Output from traceroute ebay.com

traceroute to ebay.com (66.135.192.87), 30 hops max, 38 byte packets
1 192.168.20.252 (192.168.20.252) 0.525 ms 0.421 ms 0.420 ms
2 *
---------------------------------------------------------------------------------
I can ping and communicate fine with the gateway and router, they are two different devices.

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: No Internet Connectivity on CentOS 4.4 Final

Post by gerald_clark » 2007/05/17 14:51:49

Since your router recieved the packet, it looks to me like a router issue.

bullium
Posts: 3
Joined: 2007/05/17 13:03:20
Contact:

Re: No Internet Connectivity on CentOS 4.4 Final

Post by bullium » 2007/05/17 16:10:51

[quote]
gerald_clark wrote:
Since your router recieved the packet, it looks to me like a router issue.[/quote]
I was thinking the same thing, so I opened a ticket with Cisco, and it turns out it was a firewall configuration issue. Thanks to all for the help! I really wanted to believe it wasn't a linux issue, now I can rest assured it wasn't.

Post Reply

Return to “CentOS 4 - Networking Support”