Page 1 of 1

Fresh install of network.

Posted: 2007/03/09 07:19:08
by softdel
Hi, everyone!

I have just done a fresh install of the latest CentOS Server.

The machine itself is fairly new...maybe, last year. But when the system started first time, the network gave me the "is the cable unplugged" message, even though, it was all plugged in. So i thought, maybe there was something wrong with that onboard lan, so i put a 3com pci network adapter in there, plugged it into the router, and then let it picked it up fine, i now have eth0 and eth1 but they both fail to connect to the network.

There is nothing wrong with the cable, as i am using the one from my min pc, and i have tried another, just in case.

Any ideas what this could be?

(router is a BT HomeHub 967E...)

...additionally all the guides are useless, as they are all in a GUI

Re: Fresh install of network.

Posted: 2007/03/09 11:24:30
by Lenard
As a suggestion to both /etc/sysconfig/network-scripts/ifcfg-ethX files add the router's internal IP address to them.

Example line to add, adjust for the router's actual internal IP address: GATEWAY=

Re: Fresh install of network.

Posted: 2008/02/10 13:03:27
by softdel
That worked fine, what an odd issue, thanks.