optiplex gx150 - wake on lan

Issues related to configuring your network
Post Reply
cubbyboy57
Posts: 4
Joined: 2006/04/17 03:12:05

optiplex gx150 - wake on lan

Post by cubbyboy57 » 2007/01/24 15:12:29

I have a Dell Optiplex GX150 with Intel chipset 815 / integrated NIC.

I am trying to configure the Wake On Lan feature. I read the "wake on lan how to?" thread and have got the issue down to either the shutdown is turning off the NIC or the NIC drivers are not supporting the feature.

I have a hard drive with WinXP configured for this machine and the WOL works fine, but it didn't with the default windows drivers - I had to change to the intel drivers for this chipset.

Basically my NIC is turning off when I use the Centos harddrive, but doesn't when I use the WinXP.

Can someone point me to where I may find out how to configure the NIC to access the WOL? I ran the ethtool and it doesn't show the support.

james

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: optiplex gx150 - wake on lan

Post by pjwelsh » 2007/01/24 15:47:56

Please make sure to hit "F2" on bootup, get into BIOS, scroll down towards the bottom and make sure that "Remote Wake Up" is "On"

cubbyboy57
Posts: 4
Joined: 2006/04/17 03:12:05

Re: optiplex gx150 - wake on lan

Post by cubbyboy57 » 2007/01/24 17:21:45

Yes it is, I have 2 hard drives if I put in the winXP drive it works, if I put in the Centos drive it doesn't, so I am sure it is not the bios. I can see the light on the connector stays on when the winXP drive is in the box it is off when the Centos drive is in the box. I am not sure what is turning off the card.

foxb
Posts: 1927
Joined: 2006/04/20 19:03:33
Location: Montreal/QC

Re: optiplex gx150 - wake on lan

Post by foxb » 2007/01/24 17:31:24

There was a thread about this issue long time ago
http://www.centos.org/modules/newbb/viewtopic.php?topic_id=5808&forum=27&post_id=18449#forumpost18449

I remember reading somewhere that there is an option in ACPI configuration to not shut down completely LAN (the issue is with some MBs), but where???? i do not remember....

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: optiplex gx150 - wake on lan

Post by pjwelsh » 2007/01/24 18:00:17

A quick google has peeps with similar issues even under Windows (and using Dell Client Configuration Utility "DCCU"). Some indications want to blame switches (for trying to block "smurf" attatcks). Most report inconsistant behavior.

Are you using the utility to send the magic-packet?

I will try to check one of our gx150's here the way you are (unless you utility is Windows based)

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: optiplex gx150 - wake on lan

Post by pjwelsh » 2007/01/24 18:17:01

http://article.gmane.org/gmane.linux.network/53413/match=3c59x+wol
from the post:
The 3c59x.c in kernel 2.6.18 (and as I see later ones too) attempts
to enable PME from the D0 state. The PME config space on Dell Optiplexs
for this chip has a zero in the capabilities as it doesn't 'wake from d0'.

So the pci_wake call fails, its result is not tested, so no error is reported.

The routine changes the wake request from 0 to D3_hot. This fix
causes wake on lan (WOL) to work properly on older Dell Optiplex models.

cubbyboy57
Posts: 4
Joined: 2006/04/17 03:12:05

Re: optiplex gx150 - wake on lan

Post by cubbyboy57 » 2007/01/25 09:08:43

Thanks for the info, sorry I don't know how to apply the patch. Any help would be appreciated.

james

cubbyboy57
Posts: 4
Joined: 2006/04/17 03:12:05

Re: optiplex gx150 - wake on lan

Post by cubbyboy57 » 2007/01/25 14:08:21

sorry should have read the post closer, no I do not use any utilities -- I had to get the correct Dell drivers for the NIC before there was an option in WinXP for "enh Power Option" which was off by default. Once I turned that on the NIC stayed alive after shutdown and the WOL worked. I am guessing this patch does something similar.

I send the magic packet via AMD's MAGPAC utility.

Post Reply

Return to “CentOS 4 - Networking Support”