samba server asking/ not accepting password.

Issues related to configuring your network
Post Reply
notmyrealemail
Posts: 11
Joined: 2007/01/19 02:29:12
Contact:

samba server asking/ not accepting password.

Post by notmyrealemail » 2007/01/19 03:09:54

samba server asking/ not accepting password.

I recently wiped my fedora core 5 file server and went to centOS 4.4, this machine is ganna be a samba server and a router/dns/dhcp server, but one at a time. I am having some trouble with my smb shares.

//miller is the server I am having trouble accessing. It constantly asks for a password and not accepting the userpassword I have assigned to the shares, the root password, or an extra account I created for shits and giggles while troubleshooting. The way I have it configured, I was thinking would have read only access with no password at all.


HEre are my smb.conf declarations

+++++++++++++++++++++++++++
[stick_side]
path = /mnt/stick_side
public = yes
guest ok = yes
valid users = miller
browsable = yes
writable = no
create mask = 0765



[glove_side]
path = /mnt/glove_side
guest ok = yes
valid users = miller
browsable = yes
public = yes
writable = yes
create mask = 0777

++++++++++++++++=

these permissions are temp, untill i upload 300gb or so of data this sever will host to my lan.

I have chmoded the folders I am trying to server, or at least the root folders, relative to /mnt

[root@miller mnt]# ls
glove_side stick_side
[root@miller mnt]# chmod 0777 glove_side
[root@miller mnt]# chmod 0777 stick_side


I dislabled SE linux on the install and ensured it was disabled when i fully disabled iptables via the kde gui. I am trying to fully stear away from gui changes, i like to do whatever i can through a consol.

after these changes, i have done a /etc/init.d/smb restart, /etc/init.d/network restart and even a full reboot.

Hmm, what other info may be useful?

im using dhcp on eth0 right now, untill i geta round to setting this up as my main router, firewall between my lan and my isp.

when i try to do a \\miller from xp boxes, the hostname resovles, we are all in teh same work group

Here are my full firewall and smb.conf, firewall is disabled fully now until its working
http://notmyrealdomain.com/iptables
http://notmyrealdomain.com/smb.conf[root@miller mnt]# ls
glove_side stick_side
[root@miller mnt]# chmod 0777 glove_side
[root@miller mnt]# chmod 0777 stick_side



I have also tried accessing the shares by direct ip, for shits and giggles again, because dhcp is assigned my my linksys vpn router, and im not having any resolution problems with my current dns setup.

again, selinux is fullly disabled.

While i am waiting for a replly, i think im ganna format my MC5 box and go with ubuntu on there.

Ur suggestions are all appreciated
let me know if you want to post any config files, im sure im missing something simple

--------------here are my testparm results

[root@miller init.d]# testparm smb
Load smb config files from smb
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ -f /etc/init.d/functions ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/init.d/functions
params.c:Parameter() - Ignoring badly formed line in configuration file: elif [ -f /etc/rc.d/init.d/functions ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/rc.d/init.d/functions
params.c:Parameter() - Ignoring badly formed line in configuration file: else
params.c:Parameter() - Ignoring badly formed line in configuration file: exit 0
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
params.c:Parameter() - Ignoring badly formed line in configuration file: unset TMPDIR
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/sysconfig/network
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ -f /etc/sysconfig/samba ]; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/sysconfig/samba
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
Processing section "[${NETWORKING} = "no"]"
No path in service ${NETWORKING} = "no" - using /tmp
Processing section "[-f /etc/samba/smb.conf]"
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: start() {
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Starting $KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: daemon smbd $SMBDOPTIONS
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Starting $KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: daemon nmbd $NMBDOPTIONS
Unknown parameter encountered: "RETVAL2"
Ignoring unknown parameter "RETVAL2"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
No path in service -f /etc/samba/smb.conf - using /tmp
Processing section "[$RETVAL -eq 0 -a $RETVAL2 -eq 0]"
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: stop() {
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Shutting down$KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc smbd
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Shutting down$KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc nmbd
Unknown parameter encountered: "RETVAL2"
Ignoring unknown parameter "RETVAL2"
No path in service $RETVAL -eq 0 -a $RETVAL2 -eq 0 - using /tmp
Processing section "[$RETVAL -eq 0 -a $RETVAL2 -eq 0]"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo ""
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: restart() {
params.c:Parameter() - Ignoring badly formed line in configuration file: stop
params.c:Parameter() - Ignoring badly formed line in configuration file: start
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: reload() {
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Reloading smb.conf file: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc smbd -HUP
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus() {
params.c:Parameter() - Ignoring badly formed line in configuration file: status smbd
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: status nmbd
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ $? -ne 0 -o $RETVAL -ne 0 ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: return 1
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
params.c:Parameter() - Ignoring badly formed line in configuration file: }
Unknown parameter encountered: "if [ "$1""
Ignoring unknown parameter "if [ "$1""
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus
params.c:Parameter() - Ignoring badly formed line in configuration file: exit $?
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
Processing section "[-w /etc/samba/smb.conf]"
params.c:Parameter() - Ignoring badly formed line in configuration file: case "$1" in
params.c:Parameter() - Ignoring badly formed line in configuration file: start)
params.c:Parameter() - Ignoring badly formed line in configuration file: start
params.c:Parameter() - Ignoring badly formed line in configuration file: stop)
params.c:Parameter() - Ignoring badly formed line in configuration file: stop
params.c:Parameter() - Ignoring badly formed line in configuration file: restart)
params.c:Parameter() - Ignoring badly formed line in configuration file: restart
params.c:Parameter() - Ignoring badly formed line in configuration file: reload)
params.c:Parameter() - Ignoring badly formed line in configuration file: reload
params.c:Parameter() - Ignoring badly formed line in configuration file: status)
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus
params.c:Parameter() - Ignoring badly formed line in configuration file: condrestart)
No path in service -w /etc/samba/smb.conf - using /tmp
Processing section "[-f /var/lock/subsys/smb]"
params.c:Parameter() - Ignoring badly formed line in configuration file: *)
params.c:Parameter() - Ignoring badly formed line in configuration file: echo $"Usage: $0 {start|stop|restart|reload|status|condrestart}"
params.c:Parameter() - Ignoring badly formed line in configuration file: exit 1
params.c:Parameter() - Ignoring badly formed line in configuration file: esac
params.c:Parameter() - Ignoring badly formed line in configuration file: exit $?
No path in service -f /var/lock/subsys/smb - using /tmp
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]

[${NETWORKING} = "no"]
path = /tmp

[-f /etc/samba/smb.conf]
path = /tmp

[$RETVAL -eq 0 -a $RETVAL2 -eq 0]
path = /tmp

[-w /etc/samba/smb.conf]
path = /tmp

[-f /var/lock/subsys/smb]
path = /tmp
[root@miller init.d]# testparm smb.conf
Load smb config files from smb.conf
params.c:OpenConfFile() - Unable to open configuration file "smb.conf":
No such file or directory
Error loading services.
[root@miller init.d]# testparm smb.conf
Load smb config files from smb.conf
params.c:OpenConfFile() - Unable to open configuration file "smb.conf":
No such file or directory
Error loading services.
[root@miller init.d]# testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[stick_side]"
Processing section "[glove_side]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]
workgroup = DARK_SIDE
server string = Samba Server
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
dns proxy = No
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[stick_side]
path = /mnt/stick_side
valid users = miller
create mask = 0765
guest ok = Yes

[glove_side]
path = /mnt/glove_side
valid users = miller
read only = No
create mask = 0777
guest ok = Yes
[root@miller init.d]# testparm smb
Load smb config files from smb
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ -f /etc/init.d/functions ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/init.d/functions
params.c:Parameter() - Ignoring badly formed line in configuration file: elif [ -f /etc/rc.d/init.d/functions ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/rc.d/init.d/functions
params.c:Parameter() - Ignoring badly formed line in configuration file: else
params.c:Parameter() - Ignoring badly formed line in configuration file: exit 0
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
params.c:Parameter() - Ignoring badly formed line in configuration file: unset TMPDIR
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/sysconfig/network
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ -f /etc/sysconfig/samba ]; then
params.c:Parameter() - Ignoring badly formed line in configuration file: . /etc/sysconfig/samba
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
Processing section "[${NETWORKING} = "no"]"
No path in service ${NETWORKING} = "no" - using /tmp
Processing section "[-f /etc/samba/smb.conf]"
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: start() {
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Starting $KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: daemon smbd $SMBDOPTIONS
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Starting $KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: daemon nmbd $NMBDOPTIONS
Unknown parameter encountered: "RETVAL2"
Ignoring unknown parameter "RETVAL2"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
No path in service -f /etc/samba/smb.conf - using /tmp
Processing section "[$RETVAL -eq 0 -a $RETVAL2 -eq 0]"
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: stop() {
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Shutting down$KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc smbd
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
Unknown parameter encountered: "KIND"
Ignoring unknown parameter "KIND"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Shutting down$KIND services: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc nmbd
Unknown parameter encountered: "RETVAL2"
Ignoring unknown parameter "RETVAL2"
No path in service $RETVAL -eq 0 -a $RETVAL2 -eq 0 - using /tmp
Processing section "[$RETVAL -eq 0 -a $RETVAL2 -eq 0]"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo ""
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: restart() {
params.c:Parameter() - Ignoring badly formed line in configuration file: stop
params.c:Parameter() - Ignoring badly formed line in configuration file: start
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: reload() {
params.c:Parameter() - Ignoring badly formed line in configuration file: echo -n $"Reloading smb.conf file: "
params.c:Parameter() - Ignoring badly formed line in configuration file: killproc smbd -HUP
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: echo
params.c:Parameter() - Ignoring badly formed line in configuration file: return $RETVAL
params.c:Parameter() - Ignoring badly formed line in configuration file: }
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus() {
params.c:Parameter() - Ignoring badly formed line in configuration file: status smbd
Unknown parameter encountered: "RETVAL"
Ignoring unknown parameter "RETVAL"
params.c:Parameter() - Ignoring badly formed line in configuration file: status nmbd
params.c:Parameter() - Ignoring badly formed line in configuration file: if [ $? -ne 0 -o $RETVAL -ne 0 ] ; then
params.c:Parameter() - Ignoring badly formed line in configuration file: return 1
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
params.c:Parameter() - Ignoring badly formed line in configuration file: }
Unknown parameter encountered: "if [ "$1""
Ignoring unknown parameter "if [ "$1""
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus
params.c:Parameter() - Ignoring badly formed line in configuration file: exit $?
params.c:Parameter() - Ignoring badly formed line in configuration file: fi
Processing section "[-w /etc/samba/smb.conf]"
params.c:Parameter() - Ignoring badly formed line in configuration file: case "$1" in
params.c:Parameter() - Ignoring badly formed line in configuration file: start)
params.c:Parameter() - Ignoring badly formed line in configuration file: start
params.c:Parameter() - Ignoring badly formed line in configuration file: stop)
params.c:Parameter() - Ignoring badly formed line in configuration file: stop
params.c:Parameter() - Ignoring badly formed line in configuration file: restart)
params.c:Parameter() - Ignoring badly formed line in configuration file: restart
params.c:Parameter() - Ignoring badly formed line in configuration file: reload)
params.c:Parameter() - Ignoring badly formed line in configuration file: reload
params.c:Parameter() - Ignoring badly formed line in configuration file: status)
params.c:Parameter() - Ignoring badly formed line in configuration file: rhstatus
params.c:Parameter() - Ignoring badly formed line in configuration file: condrestart)
No path in service -w /etc/samba/smb.conf - using /tmp
Processing section "[-f /var/lock/subsys/smb]"
params.c:Parameter() - Ignoring badly formed line in configuration file: *)
params.c:Parameter() - Ignoring badly formed line in configuration file: echo $"Usage: $0 {start|stop|restart|reload|status|condrestart}"
params.c:Parameter() - Ignoring badly formed line in configuration file: exit 1
params.c:Parameter() - Ignoring badly formed line in configuration file: esac
params.c:Parameter() - Ignoring badly formed line in configuration file: exit $?
No path in service -f /var/lock/subsys/smb - using /tmp
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

# Global parameters
[global]

[${NETWORKING} = "no"]
path = /tmp

[-f /etc/samba/smb.conf]
path = /tmp

[$RETVAL -eq 0 -a $RETVAL2 -eq 0]
path = /tmp

[-w /etc/samba/smb.conf]
path = /tmp

[-f /var/lock/subsys/smb]
path = /tmp
[root@miller init.d]#

-notmyrealemail
with the same gmail

billwest
Posts: 153
Joined: 2006/11/19 10:50:31
Location: Perth, Western Australia

Re: samba server asking/ not accepting password.

Post by billwest » 2007/01/19 11:06:04

Faark! What an output........


Anyway, try this:


[global]

security = share




Bill.

arrfab
Site Admin
Posts: 876
Joined: 2005/01/03 21:30:54
Location: /country/belgium
Contact:

samba server asking/ not accepting password.

Post by arrfab » 2007/01/19 17:06:22

Can you consider just pasting the actual smb.conf file ... and not the output of a malformed command you type .... ?
Anyway, you didn't tell us the content of your /etc/samba/smbpasswd file (or other file if you choose another samba passwd backend) ...

notmyrealemail
Posts: 11
Joined: 2007/01/19 02:29:12
Contact:

Re: samba server asking/ not accepting password.

Post by notmyrealemail » 2007/01/22 18:42:05

Thanks billwest. That is what I did to fix the issue. I was looking around through the samba gui options and changed the security level from user to share to resolve the problem.

Post Reply

Return to “CentOS 4 - Networking Support”