Page 1 of 1

connection timed out - mozilla

Posted: 2005/04/03 21:05:30
by cy_bais

Just installed CentOS 4. I'm not getting a consistent connection to the internet. Common sites like yahoo, msn and google will time out. I'm able to connect to the CentOS homepage :) and not much else. If I do an nslookup > get the IP address & then enter it into my mozilla browser, it connects (some, not all). I'm using DHCP to connect to the internet. I'll provide my Network settings (edited) output as well as my ifconfig result:

1. Network (DNS portion)
Hostname: (blank). Even with the default 'localhost.localdomain' entry, I still have this issue.
Primary DNS: 192.168.0.x
Secondary DNS: (blank)
Tertiary: (blank)
DNS Search: domain.ispdomain

2. Ifconfig
eth0 Link encap:Ethernet HWaddr 00:0B:CD:31:02:3C
inet6 addr: fe80::20b:cdff:fe31:23c/64 Scope:Link
RX packets:632 errors:0 dropped:0 overruns:0 frame:0
TX packets:521 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:360276 (351.8 KiB) TX bytes:71180 (69.5 KiB)
Interrupt:10 Base address:0x6000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:1154 errors:0 dropped:0 overruns:0 frame:0
TX packets:1154 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1287748 (1.2 MiB) TX bytes:1287748 (1.2 MiB)

Here's what I've tried so far:
1. Removed the DNS fields > Save > restart network services and it didn't help. In fact, it re-entered the Primary & Secondary DNS addresses that I just removed.

2. Enabled/Disabled SELinux > rebooted.

3. Enabled/Disabled Firewall rules > restart network services.

4. Modified and then reset the proxy settings within Mozilla.

1. NIC: McPhyter DP83815 card
2. Automatically obtain IP setting with DHCP
3. Automatically obtain DNS from provider
4. Static Network Routes isn't populated with information.

Not a Network admin by trade so I'm a bit lost on this one. On my previous SuSE & Vine Linux distros, I didn't have any issues connecting to the internet using the default DHCP settings.

Any help would be great.


Re: connection timed out - mozilla

Posted: 2005/04/04 13:48:30
by devil
the DNS shld be provided by yr ISP, after u get the leased IP address first ping few websites and see if name resolution is happening properly. do and "ifconfig -renew" and see if the DHCP leases IP address properly, do a "traceroute"
to some sites to see if routes are get properly from ISP side

If u get connected with an IP address and not with host-name, its DNS resolution issue from ISP side and not an issue with mozilla or CentOS

call ISP support ;-)

Re: connection timed out - mozilla

Posted: 2005/04/09 05:43:48
by cy_bais
I'm unable to use Mozilla but am using Konqueror instead because it (Konqueror) doesn't have any problem connecting to web sites.


connection timed out - mozilla

Posted: 2005/04/09 21:03:29
by arrfab
I know this can seem stupid, but : have you configured some Proxy settings in your Mozilla or Konqueror ?
If so , remove them (or set them according to your ISP rules ...)
Hope this helps ...

Re: connection timed out - mozilla

Posted: 2005/04/10 04:20:36
by cy_bais
I've compared Mozilla's & Konqueror's proxy settings. They're both set to "Connect to the internet directly." That's why it's strange to me that Konqueror works whereas Mozilla will only allow me to connect to certain sites. :(

I'll try to remove the proxy settings and see what happens.

Re: connection timed out - mozilla

Posted: 2005/04/10 04:58:39
by cy_bais
same issue - it's hit and miss with mozilla.

Re: connection timed out - mozilla

Posted: 2005/04/10 08:05:33
by Gawen
Try setting your NIC's MTU to 576 (the internet minimum value) in ifconfig_eth0. Increases header overhead, but packets of this size should pass any router. In case of success increase this value to the maximum possible, should be between around 1200 (AOL) and around 1400 (others) on ADSl lines/routers.

Re: connection timed out - mozilla

Posted: 2005/09/20 15:09:35
by cy_bais
better late than never but i figured it out via a different forum. apparently mozilla/firefox tries to use ipv6. i disabled it by doing the following:

1. about:config

2. find: network.dns.disableIPv6, set it to: true.

happy camper now - no more konqueror. the keywords i used on google are: firefox & ipv6.