Page 1 of 1

Help with Nic card

Posted: 2008/08/26 12:11:31
by jasonbailey
Hello I have centros 4.4 packaged for IRLP.net. I cannot get it to detect my nic card. I have tried two differant PC's and two differant Nic cards. Same result. Here are the details. If someone could please give me step by step directions on how to install this card I think it should work. Here is what I have learned so far:

It is a realtek 8139. It is a certified device ID 3874 by redhat.com who tells me the Kernal Module is 8139too. When I run a lspci -v command I can see it on the list. It is located at io ports e800 with memory at d5820000

If I sould like i know what I'm doing please dont be fooled. I am an centros idot and require detailed step by step directions. Thank you all for having this forum available for users and for even taking the time to respond to me.

Re: Help with Nic card

Posted: 2008/08/26 14:56:35
by herrold
The bottom line is that IRLP is a downstream fork of CentOS; that they do not release their sources or patches in a FOSS friendly fashion I could understand in spending a couple days in IRC helping a person attempt to support a proprietary card.

CentOS 4.4 is wayy stale. IRLP needs to not nail to a vulnerable version. see our [url=http://wiki.centos.org/TipsAndTricks/BrokenVserver]Broken VServer[/url] wiki article.

In the mean time, buy a card. like a used Intel eePro for $5 off eBay that 'just works'. It is not worth the time you will spend fighting non-supported hardware in.

Sorry to be downcast, but there is no percentage fighting this one -- a stale version; unable to update alone makes it not worth solving

73 de wb8sky

-- Russ herrold

Re: Help with Nic card

Posted: 2008/08/26 22:38:06
by jasonbailey
Ok thanks for the info. It just seems sad as I have tried two nic cards that came out of 386 machines that worked fine previous. Additonally one of the pc's had a "built in" ethernet jack on its motherboard, again same results. Thats three failed attempts to make centos4 recoginze nic card. I figured it would be a simple series of commands as the lspci -v command results in providing the data I thought would be necessary to install the device. Can I not go to Walmart or some local retailer and buy a Nic card? Or do you suggest the Intel eePro off ebay? The fact that redhat has certified the device as compatible is of no use?

Re: Help with Nic card

Posted: 2008/08/26 22:45:40
by jasonbailey
Ooops forgot to add that I searched ebay for the "Intel eePro" and it returned zero results. Please provide exact model number info the "card that just works" so that I can get the IRLP up and running making it fun for all us hams :-)

Re: Help with Nic card**IT WORKS!***

Posted: 2008/08/28 13:19:54
by jasonbailey
**********Got it to work heres how*************

This is an update to my previous post. I fumbled my way through it and the following information is a summary of what I did.

At the top of the file (log in as root user and on the command prompt type) /etc/modprobe.conf

Then add this line:

alias eth0 8139too

Make sure there are no other lines containing alias eth0 in them. Write the file (save) then re boot.

Upon reboot eth0 will return green (ok) rather then the previous red (failed) on the systems automatic hardware self check.


*****NOTE ABOUT 8139too********** 8139too is specific to my card to get this info for your card try the site: http:/hardware.redhat.com Look for your card. Get any numbers off of it like the manufacturer and model. Also the biggest IC on the board may give you a clue by reading the numbers directly from it. Your card will hopefully be listed at a certifed device. If so under the field listed as "Detail Notes: Kernel Module: XXXXXX" simply replace my 8139too with your number.

Good luck and I hope this info can assist someone, someday.

Re: Help with Nic card**IT WORKS!***

Posted: 2008/08/28 14:01:12
by AlanBartlett
Thanks for letting us know that you have resolved this issue and that you now have network connectivity.