Page 1 of 1

CentOS 4.3 on PowerEdge 2900 Perc 6i RAID problems

Posted: 2008/07/26 15:58:00
by reillyse
Hi All,
I'm new to CentOS so please excuse me if I'm not making a large amount of sense. I've been pulling my hair out trying to get a 4.3 installation on a server for the last week and I'm getting nowhere so I thought I'd ask around and see if theres something obvious I'm missing. Here goes,

The installation is CentOS 4.3 and I'm using kickstart from another server(PXE). I don't have a choice in this matter as all the software is bundled up with the installation.
After much hassle I got the new server to start booting from the pxe installation server, but it fails at a "No Valid Devices" error.

I reckoned 4.3 doesn't support the Perc 6i controller so I tried to download the drivers from the dell website. I stuck the drivers on the pxe server (driver-source nfs:/...) and have been trying to boot.
Anaconda downloads the file but can't seem to mount it, I can mount the driver disk on the other server but when I switch to a shell from anaconda(new server) I can't mount it (I get a "could not find a spare loop device) and looking in the anaconda log I can see
"failed to open /tmp/drivers/modules.pcimap:no such file or directory"
after anaconda mounted the driver disk and failed. This file does not exist in the driver disk.



I've copied across the driver disk myself mounted it and loaded the modules

mptbase mptscsi.. mptsas

but even then I can't find the RAID array anywhere (i'm not 100% sure what the device would be called anyway, but I've searched all of /dev)




So,
thats my story hopefully somebody can tell me what I'm doing wrong,

thanks

Re: CentOS 4.3 on PowerEdge 2900 Perc 6i RAID problems

Posted: 2008/07/29 11:31:57
by reillyse
ok , I've figured this stage in the problem out.

Solution is to go to the LSI website, download their driver (megaraid_sas) img file and use it as the driver disk

http://www.lsi.com/storage_home/products_home/internal_raid/megaraid_sas/megaraid_sas_8408e/index.html

megaraid_sas-v00.00.03.13-1-rhel40-all.img worked for me

Re: CentOS 4.3 on PowerEdge 2900 Perc 6i RAID problems

Posted: 2008/07/29 12:27:08
by reillyse
OK,
So by using the different driver disk in that manner I got Centos to install fine via PXE on to the server. Unfortunately now when I reboot into to the server I get a Kernel Panic.


after loading the megaraid_sas.ko module
..
..
Creating root device
mkrootdev: label /1 not found
Mounting root filesystem
mount: error 2 mounting ext3
mount: error 2 mounting nont
Switching to new root
switchroot: mount failed : 22
umount /initrd/dev failed: 2
kernel panic



So I seem to be stuck again.
I read of a possible solution invloving mkinitrd to recreate the ramdisk image with the new megaraid drivers, but do I still need to do this seeing as the module appears to already be loaded?

I've tried changing the labler /dev/sda1-5 with no luck,


Any ideas?


thanks

Re: CentOS 4.3 on PowerEdge 2900 Perc 6i RAID problems

Posted: 2008/07/31 23:04:14
by reillyse
ok after much hassle with RAID drivers and PXE installs, I stuck ubuntu on the machine and executed the kickstart file by hand...