Kernel Memory Recognition Issue

Issues related to hardware problems
Post Reply
atlastc
Posts: 2
Joined: 2008/01/23 16:13:05

Kernel Memory Recognition Issue

Post by atlastc » 2008/01/23 16:21:27

I've got a system with the following:

Motherboard: Gigabyte GA-M57SLI-S4
RAM: 8GB (4 x 2GB)
OS: CentOS 4.6 + Updates
Kernel: Linux [systemname] 2.6.9-67.0.1.ELsmp #1 SMP Wed Dec 19 15:19:57 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

On POST, the system shows memory as 8388608K. In the BIOS, base memory is 640K and extended memory is 8191M.

However, when I boot into the system, only about 6.7GB of ram is usable:


Memory: 6627032k/7602176k available (2126k kernel code, 0k reserved, 1313k data, 212k init)



total used free shared buffers cached
Mem: 6627648 1847752 4779896 0 10608 1657160
-/+ buffers/cache: 179984 6447664



MemTotal: 6627648 kB
MemFree: 4779896 kB
Buffers: 10640 kB
Cached: 1657400 kB
SwapCached: 0 kB
Active: 1349192 kB
Inactive: 382868 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 6627648 kB
LowFree: 4779896 kB
SwapTotal: 10482404 kB
SwapFree: 10482404 kB
Dirty: 76 kB
Writeback: 0 kB
Mapped: 1259276 kB
Slab: 22392 kB
CommitLimit: 13796228 kB
Committed_AS: 450684 kB
PageTables: 4268 kB
VmallocTotal: 536870911 kB
VmallocUsed: 267764 kB
VmallocChunk: 536603127 kB
HugePages_Total: 0
HugePages_Free: 0
Hugepagesize: 2048 kB


Based on some suggestions I've found, I've tried adding mem=10G and mem=8G to the kernel boot parameters with no luck.

I've also tried CentOS 5.1 with the same results.

There also don't appear to be any options in the BIOS that allow me to tweak my memory settings, but the system itself *appears* to recognize the full 8GB.

Does anyone have any ideas as to what I should try next? Any input is greatly appreciated.

Regards,

Nate D.

atlastc
Posts: 2
Joined: 2008/01/23 16:13:05

Re: Kernel Memory Recognition Issue

Post by atlastc » 2008/01/24 16:29:13

FYI - I originally posted my question here:

http://www.linuxquestions.org/questions/linux-software-2/centos-kernel-memory-recognition-issue-615752/#post3032645

Figured I'd close the loop in case my post never gets responded to in the CentOS forums.

ordinary
Posts: 6
Joined: 2006/03/01 20:08:42

Kernel Memory Recognition Issue

Post by ordinary » 2008/01/30 17:30:21

atlastc, I have very similar problems with a very similar configuration. My board is a GA-M57SLI-S4 rev2, my OS is Fedora 8, and I have 4GB of ram, but the problem is very similar. I posted a question on FedoraForum, but received no reply (yet?). See http://forums.fedoraforum.org/showthread.php?t=179739

Did you ever resolve this issue?

It seems like several folks at LinuxQuestions assumed that you had on-board video and lead the discussion astray. I may post to that thread as well.

The motherboard's documentation says it will support 16GB. The first time I booted after upgrading from 2GB (i.e. 2x1) to 4GB (4x1), the BIOS only claimed ~3.2 GB, but after I reset the CMOS and booted into the BIOS again, it showed all 4GB. Booting into Fedora 8 still shows ~3.2GB however.

ordinary
Posts: 6
Joined: 2006/03/01 20:08:42

Re: Kernel Memory Recognition Issue

Post by ordinary » 2008/01/30 21:28:02

I think my problem was a buggy and lying BIOS. Sometimes it would show 4095MB extended and sometimes 3327MB. That was BIOS FE for the Gigabyte GA-M57SLI-S4 rev2, to which I had upgraded for its virtualization support. Updating to BIOS FFC fixed my memory access problem, and now I can see all of my new memory. Maybe this info will help someone else.

Phil

Post Reply

Return to “CentOS 4 - Hardware Support”