Page 1 of 1

Monitor refresh rate won't stick

Posted: 2007/11/12 00:55:07
by marsom
Centos 4.5, usually using Gnome. The computer had a multisync monitor that worked OK, but it quit working a few days ago so I replaced it with one of several spares I have. No go. Borrowed a multi-sync monitor temporarily and discoverd that the refresh rate was set to 75 Hz, which my spare monitors won't support. No problem, I set the rate to 60 Hz and hot-swapped the monitors, worked fine.

But on reboot it went back to 75 Hz, and nothing I can do will change that. I checked the "Set default for this computer only" (whatever that means - it makes little sense to me the way it is worded) but no difference, it always goes back to 75 Hz when booted.

So how do I get this to stick? Is the value hidden in a conf file somewhere? I've no problem editing such if that's required. In the meantime, I've had to give back the borrowed monitor and am not able to use CentOS very easily (although I can boot it with no monitor and access it via VNC or SSH, that's not entirely what I want to do).


P.S. Suggestions to get another multisync monitor, while well meaning, don't really fit my requirements, nor do they solve the fundamental problem.

Nevermind, got it.

Posted: 2007/11/12 07:32:30
by marsom
/etc/X11/xorg.conf. There's a line in the Monitor section that says

VertRefresh 50.0 - 120.0

I just changed 120.0 to 60.0 and it now comes up at 60 Hz when I reboot. Anyone else with the problem can take note.