Wildcat 4 Driver

Issues related to hardware problems
Post Reply
michelu_fr
Posts: 4
Joined: 2007/04/10 13:52:18

Wildcat 4 Driver

Post by michelu_fr » 2007/04/10 14:39:33

Hi folks,
I have an IBM Intellistation ZPro Type 6221-C7G 2x2.8GHz/533MHz with Wildcat4 (3DLabs) 7110 video board.
I have installed and updated CentOs 4.4 without any problems except the Wildcard card.
The available drivers from 3Dlabs are the following:

Redhat Linux Enterprise 3.0 UP
Readme: http://content.3dlabs.com/drivers/wildcat.el3.readme.txt
Redhat Linux Enterprise 3.0 SMP
Redhat Linux 9 SMP
Readme: http://content.3dlabs.com/drivers/wildcat.90.readme.txt
Redhat Linux 8 Kernel Version: 2.4.18_14
Redhat Linux 8 Kernel Version: 2.4.18_14 SMP
Redhat Linux 8 Kernel Version: 2.4.18_27
Redhat Linux 8 Kernel Version: 2.4.18_27 SMP
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version: 2.4.18_3.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_3smp.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_24.7.x.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_24.7.xsmp.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_26.7.x.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - 2.4.18_26.7.xsmp.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_27.7.x.i686.rpm
Redhat Linux 7.3 - Driver Version 0.0.2-19 - Kernel Version 2.4.18_27.7.xsmp.i686.rpm

But no Redhat Linux Enterprise 4.0 driver!

Address: http://workstation.3dlabs.com/support/drivers/

So, witch one to install?

michelu_fr
Posts: 4
Joined: 2007/04/10 13:52:18

Re: Wildcat 4 Driver

Post by michelu_fr » 2007/04/11 11:43:38

following,
I have tried the "Redhat Linux Enterprise 3.0 SMP" driver, that seems the more recent,but it fails with:
Checking Kernel source path.
/usr/src/linux-2.6.9-42.0.10.EL
Cannot locate the kernel source path.
How could I try to install the right sources there?
Regards.

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Wildcat 4 Driver

Post by pjwelsh » 2007/04/11 13:28:56

Do you have the "kernel-devel" package installed?

michelu_fr
Posts: 4
Joined: 2007/04/10 13:52:18

Re: Wildcat 4 Driver

Post by michelu_fr » 2007/04/11 19:08:31

Yes,
I have a workstation installation updated.
I have add all the groups packages about system and developement.

The sources seems to be in /usr/src/kernels/2.6.9-42.EL-i686, /2.6.9-42.EL-smp-i686, ...

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: Wildcat 4 Driver

Post by pjwelsh » 2007/04/11 19:40:49

That kernel path looks not up-to-date as a starting point...


ls -lad /usr/src/kernels/2.6.9-42.0.10.EL-*
drwxr-xr-x 17 root root 4096 Feb 28 03:55 /usr/src/kernels/2.6.9-42.0.10.EL-i686
drwxr-xr-x 17 root root 4096 Feb 28 03:55 /usr/src/kernels/2.6.9-42.0.10.EL-smp-i686

uname -r
2.6.9-42.0.10.ELsmp

run as root "yum update kernel-devel" please.

michelu_fr
Posts: 4
Joined: 2007/04/10 13:52:18

Re: Wildcat 4 Driver

Post by michelu_fr » 2007/04/11 21:15:40

Sorry, That directory was in my notes, before my update.
My system is now updated:

uname -r
2.6.9-42.0.10.ELsmp

Are the sources at the same place in CentOS and RHEL?

fobbio
Posts: 2
Joined: 2007/10/23 05:59:52
Contact:

Re: Wildcat 4 Driver

Post by fobbio » 2007/10/23 06:09:46

I'm having the same trouble. I just got an IBM IntelliStation 6221-W11 with a Wildcat4 7110 also. I can't get X going, there was a hint on linuxquestions.org to try the glint driver, but I haven't tried this yet. I'd bet that DRI wouldn't work though. The driver installs under CentOS 3 easily. However, running it on CentOS 4 seems to not work.

They state on the site it will work with 2.4.x kernels only. That may be a critical problem. It doesn't quite make sense to me though, if it's compiling the kernel, it should work regardless of the version, no?

I'm trying to contact 3Dlabs to see if the Realizm driver is compatible with the Wildcat4 series. I should have a reply in the next week or so. I can certainly install the Realizm driver under CentOS 4 without issue, but it doesn't seem to work immediately with the driver. But it might have some option or so that enables the Wildcat4.

I'd rather work under the 2.6 kernel if I could. I've been trying to get mesa-glx support under CentOS 3, but haven't gotten it to work. I need to be able to write OpenGL programs and GLX is an easy framework to use.

fobbio
Posts: 2
Joined: 2007/10/23 05:59:52
Contact:

Re: Wildcat 4 Driver

Post by fobbio » 2007/10/23 23:50:58

I contacted 3Dlabs and they replied that the Wildcat Realizm driver is NOT compatible with the Wildcat4 series. They suggested I try the RHEL3 driver which is what I'm going to do with CentOS3.

Does anyone know if it's possible to install mesa-glx and freeglut into CentOS3? Fedora Core 1 and afterward included these packages, as a result I'm downloading FC1 core files to see if I can make it fit.

The best advice they could give me is to try and fit our needs around the currently supporting distributions. That's what I'm going to try. Although, as it stands now, I can't even power down the system automatically.

If not, I'm going to have to replace it with a GeForce 6200, which couldn't possibly be as powerful.

Post Reply

Return to “CentOS 4 - Hardware Support”