INSTALLING NETWORK CARD

Issues related to hardware problems
Darrel
Posts: 15
Joined: 2007/01/29 08:35:45

Re: INSTALLING NETWORK CARD

Post by Darrel » 2007/02/06 03:31:14

i have all the privelege regarding with the access, the thing is whenever i go to SYSTEM SETTINGS =>NETWORK, it doesnt display anthing not a single hardware, though i have a built-in and a PCI LAN card, so i tried adding the PCI network card that i have inserted in the PCI slot. and i tried adding it NEW=>ETHERNET CONNECTION=>OTHER CARD, but i cant find it! it seems that i have to install the driver manually, i have the driver its in a floopy disk, but my problem is i dont know how to do it. this is the first i have encountered this problem, i have installed a few computer units witH CentOS 4.4, and there no problem at all, the usual scenario is, before installing all the packages CentOS 4.4 will ask me to configure the network, and theres no problem with, i know the DNS, gateway,domain name and the subnet mask.

But when i install CentOS 4.4 with the computer that has a problem regarding with the NIC, i know there's something wrong with the PC, because, CentOS 4.4 didnt ask me to configure the Network before proceeding with the installion of the packages. Not like the previous installation i have done before.

Can u teach how can i install the NETWORK CARD that i have manually,,, or there is any other way i can install the driver of my NIC so that i can configure it using GUI.

Lenard
Posts: 2283
Joined: 2005/11/29 02:35:25
Location: Indiana

Re: INSTALLING NETWORK CARD

Post by Lenard » 2007/02/06 11:44:44

As I have already asked, provide the output from the typed command; /sbin/lspci -v

If you need to save it as a file for posting then use; /sbin/lspci -v > hardware.txt

The plus kernels support more hardware then the standard kernel try installing the latest version for you system. Hint: rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" kernel

http://isoredirect.centos.org/centos/4.4/centosplus/

reynoldsdesign
Posts: 1
Joined: 2008/09/13 22:46:04
Contact:

Re: INSTALLING NETWORK CARD

Post by reynoldsdesign » 2008/09/13 23:38:01

Hello,

First off, I may be way in over my head here. I wanted to set up a basic LAMP web server to play around with. I got CentOS installed (as far as i can tell properly), but I can't seem to get my network card to function to be able to do any updates / downloads.

What I'm showing for my network card when I type in: /sbin/lspci -v is:

Ethernet Controller: Accton Technology Corporation SMC2-1211TX (rev 10)
Subsystem: Hewlett-Packard Company: Unknown device 9207
Flags: bus master, medium devsel, latency 64, IRQ 10
I/O ports at 2880 [size=256]
Memory at f4100400 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

before i went into the network config i was able to do the /sbin/modprobe -v tulip and dmfe and get a result back. now i'm not getting anything. its very probable that i messed something up.

below is my ethernet configuration setup. i tried to follow the setup in the instructions below but wasn't sure what to put in:
Name: eth0
Device: eth0
Use DHCP [ ]
Static IP 192.168.0.100
Netmask: 255.255.255.0
Default gateway IP 192.168.0.1

its possible that i need to install a new kernel (which i have no idea how to do also).

any help on this would be greatly appreciated.

thanks

eric

gerald_clark
Posts: 10642
Joined: 2005/08/05 15:19:54
Location: Northern Illinois, USA

Re: INSTALLING NETWORK CARD

Post by gerald_clark » 2008/09/15 14:50:44

Please do NOT hijack someone else's old thread.

Post Reply

Return to “CentOS 4 - Hardware Support”