Sound Problem

Issues related to hardware problems
Post Reply
Posts: 2
Joined: 2005/06/16 00:43:05

Sound Problem

Post by Justbill » 2005/10/11 11:25:09

I just installed CentOS 4.1. Everything seems to be working except my sound. I tried Soundcard Detection, under Applications>System Settings>Soundcard Detection, I tried typing "alsa" in the terminal, I also tried "alsamixer" in the terminal.
I'm sure I am missing something here. Also when I tried "Soundcard Detection" it popped up a window "no soundcards detected". I have a Soundblaster soundcard in this machine, whiched worked with FC4 and Suse 9.3. My Machine is a:
Compaq Presario1426NX
2.93Ghz Pentium 4
512MB PC2-3200 DDR2 SDRAM
160GB 7200RPM Serial ATA hard drive

Thanks in advance for any help


Posts: 15
Joined: 2005/09/24 16:21:23
Location: East TX, USA

Re: Sound Problem

Post by hordjr » 2005/10/11 17:39:52

Distros, even RH/Fedora builds their kernel with different modules. Can't say about your box, but here's what I experienced. Sound (different, but on board) worked in FC3, not in CentOS. Found the drivers were not built. Got all the kernel stuff, changes in menuconfig were;

These all were "is not set", made changes to =m
CONFIG_ISAPNP=m # note, important in my case.

Make new kernel, sound picked up on first boot. Did the alsamixer and store stuff. Everything worked like new.

Looking at /boot/config....... here's what I see on SB. Can't say if yours is here though.
# CONFIG_SND_SB8 is not set
# CONFIG_SND_SB16 is not set
# CONFIG_SND_SBAWE is not set

At the worst, you'll need to build the kernel for your sound card.

Posts: 2
Joined: 2005/06/16 00:43:05

Re: Sound Problem

Post by Justbill » 2005/10/11 22:02:18

I have the onboard sound disabled on this box. I have never tried to build a kernel, so I have not a clue what your talking about! I had to disable the onboard sound for FC4, when I installed the soundblaster.


Posts: 15
Joined: 2005/09/24 16:21:23
Location: East TX, USA

Re: Sound Problem

Post by hordjr » 2005/10/12 14:57:07

Not knowing anything about your soundcard.... To build a new kernel, being 2.6.9-11 as of now.
Note: the # means as root.
Start with all updates.
# yum update
# rpm -qa | grep kernel
Should have these;
Install what you don't have as;
# yum install kernel-sourcecode kernel-devel (etc...)
# rpm -qa | grep module
Should have;
yum install (if you don't have it)
# cd /usr/src/linux-2.6.9-11.EL/
# make mrproper
# ls -l /boot/config*
# cp /boot/config .config Plug and Play support ---> ISA Plug and Play support = *
exit menu
Sound ---> Then find your drivers for your soundcard, maybe in the ISA section or elsewhere, Press m
exit exit save
# make dep (depreciated in 2.6) ; old habit
# make modules
# make modules_install
# make
# make install (installs kernel in /boot)

# make modules; make modules_install; make; make install

Take a break until done.
Check new kernel;
# ls -l /boot
Should see your newly build kernel
Not sure what you have, but edit the grub menu.lst and comment out the hiddenmenu
# /boot/grub/menu.lst
Put # in front of hiddenmenu
Should see something like below. I added the acpi and apm parameters. I also have raid (/dev/md0)
# hiddenmenu
title CentOS (2.6.9-11.ELcustom)
root (hd0,0)
kernel /boot/vmlinuz-2.6.9-11.ELcustom ro root=/dev/md0 vga=771 acpi=off apm=power_off
initrd /boot/initrd-2.6.9-11.ELcustom.img
Save and reboot, be sure you pick the new kernel.
Hopefully kudzu finds and configures the soundcard if I didn't miss something.

No harm is done to your old kernel. If you have problems reboot and select the older kernel.

Please post back the results for the next one that comes along.

Post Reply

Return to “CentOS 4 - Hardware Support”