Page 1 of 1

Centos 4.1 crashes with hyperthreading turned on

Posted: 2005/10/08 23:49:23
by bartigas
Hello,
I'm running the following hardware with Centos 4.1:

Supermicro P8SCi Motherboard
Intel Pentium 4 630 CPU (3.0 Ghz, 2 MB L2, Hyperthreading, 800 Mhz FSB)
1 GB DDRII 533 Mhz RAM Non-ECC

I'm running in to a problem where the server crashes whenever I try to boot it with Hyperthreading turned on. It installed ok the first time, then when it tried to boot it crashed and the kernel went into "panic". I thought at this point it may be a heat issue but I checked the BIOS and it was running at 52*C. So after turning off every unnecessary option on the motherboard I tried again, this time it crashed during the install (formatting HDD). So I tried again and it installed ok but then crashed on bootup. At this point I turned off Hyperthread and it installed fine and booted fine. Turned Hyperthreading back on and it crashed again, I tried this a few times to be sure that this was the issue. There is no higher BIOS revision available for this motherboard, does anyone know of a fix for this. The server does run very well with HT turned off, but I'd like to get full performance out of it.

Thanks in advance,
Brian Artigas
Allstate Computers, LLC.

Centos 4.1 crashes with hyperthreading turned on

Posted: 2005/10/21 00:40:19
by nkendrick
I had a similar issue with an Abit board and CentOS 4.2 - smp kernel would panic during boot.

I did a bit of Googling and found some generic linux notes which led me to modify the boot instructions for the SMP kernel in /etc/grub.conf by adding acpi=ht to the end of the line as follows:

kernel /vmlinuz-2.6.9-22.ELsmp ro root=/dev/md1 rhgb quiet acpi=ht

System is rock solid now - hope it works for you.