Page 1 of 1

gmp is to old (Centos 4)

Posted: 2010/01/16 08:48:28
by lukesoft76
The gmp library is needed for compiling GCC 4.3.3. The library is very old! It is version 4.1.4 but i need a newer one (>=4.2). The gmp-project is now at 4.3.2 respectivly at 5.0.0. Does anyone have a newer RPM than that from the REPO's! By the way, i am using Centos 4, and even in Centos 5 the lib is at 4.1.4 which is was published 2005, i think.
I tried to build it on my own, but it breaks.

Any help would be appreciated!
Thx.

Best regards,
Lukesoft

Re: gmp is to old (Centos 4)

Posted: 2010/01/16 10:07:59
by lukesoft76
Jesus,
after 3 days of editing the specfile, it seems as if i managed to get around all the rpmbuild errors.
I hope that the library will work ...
The internal checks show now errors ...

we will see!

best regards

Lukesoft

gmp is to old (Centos 4)

Posted: 2010/01/16 23:49:24
by pschaff
Welcome to the CentOS fora.

All I can say is good luck, and see [url=http://wiki.centos.org/FAQ/General#head-472ce8446ebcfc82ca1800f775ba0e629ac835c7]CentOS FAQ#20[/url].