Page 1 of 1

ihave centos server 4.7 but

Posted: 2009/05/20 23:55:52
by samarasat
hi all frinds

i am new user for centos

ihave centos server 4.7 but it dont have this file libcrypto.so.0.9.8

and i want to install libcrypto.so.0.9.8 on it what steps to do that

thanks for help

ihave centos server 4.7 but

Posted: 2009/05/21 13:33:53
by gerald_clark
Do not double post.

Re: ihave centos server 4.7 but

Posted: 2009/05/21 13:34:15
by pjwelsh
"yum" is very handy for find what package that a program/file/directory belongs to. For example,
[code]yum provides */libcrypto.so.0.9.8*[/code]
will provide the answer of:
[quote]openssl-0.9.8e-7.el5.i686 : The OpenSSL toolkit Matched from: Filename : /lib/libcrypto.so.0.9.8e[/quote]
Then you can just
[code]yum install openssl[/code]

Re: ihave centos server 4.7 but

Posted: 2009/05/21 13:45:01
by gerald_clark
Why does the OP ask?
If the OP is using yum to install a program that needs this library, it should
be installing openssl automatically.
if samarasat is compiling something, maybe he shouldn't be, and needs to read
http://www.centos.org/modules/newbb/viewforum.php?forum=47

Re: ihave centos server 4.7 but

Posted: 2009/05/21 15:02:11
by pjwelsh
OP, @gerald_clark is correct. You should most likely attempt to use standard install .rpm's whenever possible. If you are trekking into custom install, you should be cautious. But if you are, you are likely wanting the "devel" package of openssl like "openssl-devel".

Re: ihave centos server 4.7 but

Posted: 2009/05/21 15:32:56
by NedSlider
Moved to C4 forum

Re: ihave centos server 4.7 but

Posted: 2009/05/21 23:46:13
by samarasat
[quote]
pjwelsh wrote:
OP, @gerald_clark is correct. You should most likely attempt to use standard install .rpm's whenever possible. If you are trekking into custom install, you should be cautious. But if you are, you are likely wanting the "devel" package of openssl like "openssl-devel".[/quote]

thank you frind