libpq4 issues during PHP5 Upgrade

Issues related to software problems
Post Reply
pendal
Posts: 2
Joined: 2009/02/27 15:49:35
Contact:

libpq4 issues during PHP5 Upgrade

Post by pendal » 2009/02/27 16:53:02

I'm trying to upgrade PHP to 5.1.6 on our centos 4.7 box.

I enabled the centosplus repo in both YUM and up2date.

I keep getting libpq4 errors when trying to update.
####
php-pgsql 5.1.6-3.el4s1.10 requires libpq.so.4
####

What is weird is that libpq.so.4 is from postgres 7.x (if i remember correctly).
we are running postgres 8.2.6 on this machine.

so if anything should it not be asking for the dep libpq.so.5??

is there anyway to force this besides reinstalling postgres?

i could try an --nodeps install, but would that actually work??

any ideas would be great.

Thanks,

Post Reply

Return to “CentOS 4 - Software Support”