Firefox/java problem

Issues related to software problems
Post Reply
Posts: 28
Joined: 2006/10/07 14:12:58

Firefox/java problem

Post by marsom » 2008/01/31 04:23:32

It worked. It used to work. It doesn't work anymore. Java no longer works in Firefox (yes, when it was working it WAS working with this version). The only remotely related thing I did that I can think of is that I installed Opera and got Java working fine it it (and it still does).

The problem seems to be with the symbolic link in the firefox plugins directory, but I've fsck it up and can't fix it. The last time this happened to me I ended up reformatting the drive, and eventually installed CentOS on a different computer altogether. But that seems a bit extreme! Here's the story.

When I installed Java and painstakingly followed the instructions on the Sun site to set up a symlink in the firefox plugins directory, it worked. After installing Opera (and in the process messing up somewhere else and installing an unneeded symlink, but I don't see how that could affect it) and getting Java to work in it, I tried Firefox (actually, a couple of days later) and Java no longer works, nor shows as a plugin. So I found the Firefox plugins directory, which is:


and found that the symlink ( was flashing. OK, removed it and tried to re-create it with:

ln -s /usr/java/jre1.6.0/plugin/i386/ns7 / .

which SEEMED to work. But it didn't. Yeah, it created a symbolic link, or actually, it seemed to create TWO of them. The first: simply points back to itself!

the second:

ns7 points to /usr/java/jre1.6.0/plugin/i386/ns7

Two problems. First, I can't delete the self-referential If I try rm it says it's a directory, if I try rmdir it says it's NOT a directory.

Second, I've been over that command line with a fine tooth comb about 20 times and I can't for the life of me see WHY it made a symbolic link called ns7 (which, by the way, I CAN delete).

So the questions are 1. how do I get rid of the undeletable file, and 2. what on earth could I be doing wrong that generates that ns7 symlink?

Hope someone can help. I'm at my wits' end. Oh, and yes, I've double and triple checked the Java directory, which seems OK. Curious, though: /usr/java/jre1.6.0/plugin/i386/ns7 contains only a symlink ns7 that points back to /usr/java/jre1.6.0/plugin/i386/ns7. That doesn't seem to make sense to me. Is that normal too?


P.S. During the Opera installation I ended up accidentally with a symlink in / and I can't remove it either (same error messages). However, it DOES point to the right place, not that it's of the slightest use there.

Posts: 28
Joined: 2006/10/07 14:12:58

OK, let's start off with easier questions.

Post by marsom » 2008/02/01 00:44:38

Maybe I am the only person in the world to have had the problems in my lead post. Maybe others have but there is no solution. In any case, let me simplify it for starters.

First, what SHOULD the contents of /usr/java/jre1.6.0/plugin/i386/ns7 be? I don't have another CentOS box to check. If anyone does, a simple ls -a (or ll) output would be fine.

Second, how can I delete the "undeletable" symlinks? To reiterate, if I try:


I get the error message "Can't delete. Is a directory". So I then try


and get the message: Can't delete, is NOT a directory. Hmmm...

So can we start with these? Anyone?


Posts: 1015
Joined: 2006/06/10 18:27:44
Location: 32 4′N 34 47′E

Firefox/java problem

Post by yyagol » 2008/02/01 06:33:19

very strange , i guess you probably mess with it. just remove the java dir and
reinstall it using the RPM or tarball from

Post Reply

Return to “CentOS 4 - Software Support”