PCRE library version error

Issues related to software problems
Post Reply
thecoolone
Posts: 5
Joined: 2006/11/24 08:44:29

PCRE library version error

Post by thecoolone » 2007/01/29 20:00:53

I was trying to upgrade php on my centos 4.4 following the instruction here:
http://www.jasonlitka.com/2006/11/30/upgrading-php-520-rhel-centos/

everything was going smoothly until i ran into an error when i was running the rpmbuild for php.spec.
During the configuration Check it gave me this error:
[i]“configure: error: The PCRE extension requires PCRE library version >= 6.6
error: Bad exit status from /var/tmp/rpm-tmp.30925 (%build)
RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.30925 (%build)”[/i]

i tried dowloading the PCRE.rpm from http://mirrors.kernel.org/fedora/core/6/source/SRPMS/pcre-6.6-1.1.src.rpm
and ran $rpm -ivh pcre-6.6-1.1.src.rpm
but it still gives me the same error.

any help in upgrading to php 5 wud be very helpful.

thanx

pjwelsh
Posts: 2629
Joined: 2007/01/07 02:18:02
Location: Central IL USA

Re: PCRE library version error

Post by pjwelsh » 2007/01/29 20:39:28

wget http://mirrors.kernel.org/fedora/core/6/source/SRPMS/pcre-6.6-1.1.src.rpm
rpmbuild --rebuild pcre-6.6-1.1.src.rpm
rpm -Uhv /usr/src/redhat/RPMS/i386/pcre-6.6-1.1.i386.rpm
rpm -Uhv /usr/src/redhat/RPMS/i386/pcre-devel-6.6-1.1.i386.rpm (maybe)

(this does not gaurantee that other programs will let you do this, however)
I have not tried this upgrade, but the *.src.rpm are built into installable .rpm's

thecoolone
Posts: 5
Joined: 2006/11/24 08:44:29

Re: PCRE library version error

Post by thecoolone » 2007/01/30 09:48:55

i did $rpmbuild -bb pcre-6.6-1.1.src.rpm

and after it gets completed i tried running rpm and get the following error:
# rpm -Uvh /usr/src/redhat/RPMS/i386/pcre-6.6-1.1.i386.rpm
error: Failed dependencies:
pcre = 4.5-3.2.RHEL4 is needed by (installed) pcre-devel-4.5-3.2.RHEL4.i386

And so i tried to install the dependencie,
# rpm -Uvh /media/cdrom/CentOS/RPMS/pcre-4.5-3.2.RHEL4.i386.rpm
Preparing… ########################################### [100%]
package pcre-4.5-3.2.RHEL4 is already installed

and then again when i run rpm i get the same error:
# rpm -Uvh /usr/src/redhat/RPMS/i386/pcre-6.6-1.1.i386.rpm
error: Failed dependencies:
pcre = 4.5-3.2.RHEL4 is needed by (installed) pcre-devel-4.5-3.2.RHEL4.i386

Now for something weird,
when i try to remove the packege it says
$rpm -fe pcre-4.5-3.2.RHEL4.i386.rpm
error: package pcre-4.5-3.2.RHEL4.i386.rpm is not installed

why is this happening, once it says package is installed and when i try to remove it says Not Intalled??

thecoolone
Posts: 5
Joined: 2006/11/24 08:44:29

Re: PCRE library version error

Post by thecoolone » 2007/01/30 13:17:49

found the solution by enabling the centosplus section:
vi /etc/yum.repos.d/CentOS-Base.repo
and making the following changes
[centosplus]
gpgcheck=1
enabled=1

and then running $yum update -y php

jasonxoxide
Posts: 80
Joined: 2006/09/11 14:35:48
Location: Exton, PA
Contact:

PCRE library version error

Post by jasonxoxide » 2007/01/30 17:23:42

If you have both pcre & pcre-devel already installed then when you run the rpm -Uvh on the 6.6 RPMs you need to specify both as arguments not one at a time.

cape
Posts: 14
Joined: 2007/06/05 20:04:00

Re: PCRE library version error

Post by cape » 2008/07/13 15:01:57

i have same exact problem but i have this both repos already enabled and still is asking me for.

[root@ i386]# rpm -Uvh pcre-6.6-1.1.i386.rpm
error: Failed dependencies:
pcre = 4.5-4.el4_6.6 is needed by (installed) pcre-devel-4.5-4.el4_6.6.i386
[root@ i386]# rpm -Uvh pcre-devel-6.6-1.1.i386.rpm
error: Failed dependencies:
pcre = 6.6-1.1 is needed by pcre-devel-6.6-1.1.i386

Post Reply

Return to “CentOS 4 - Software Support”