Can't run phpMyAdmin

Issues related to software problems
Post Reply
rcdiugun
Posts: 1
Joined: 2005/05/09 09:57:53

Can't run phpMyAdmin

Post by rcdiugun » 2005/05/09 10:05:23

I've been trying to get phpMyAdmin to work, but to no avail.

Everytime I access it through the browser I get a 403 error
[quote]Forbidden
You don't have permission to access /index.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.[/quote]

In the logs, I have this:
[quote](13) Permission denied: access to /phpMyAdmin/index.php denied.[/quote]

MySQL is working (I can login through the command line on my user account). PHP is installed but doesn't seem to be generating any logs. Am I missing something here?

pmunoz
Posts: 2
Joined: 2005/04/28 18:14:40

Can't run phpMyAdmin

Post by pmunoz » 2005/05/12 16:55:18

[quote]
rcdiugun wrote:
I've been trying to get phpMyAdmin to work, but to no avail.

Everytime I access it through the browser I get a 403 error
[quote]Forbidden
You don't have permission to access /index.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.[/quote]

In the logs, I have this:
[quote](13) Permission denied: access to /phpMyAdmin/index.php denied.[/quote]

MySQL is working (I can login through the command line on my user account). PHP is installed but doesn't seem to be generating any logs. Am I missing something here?[/quote]

Perhaps it is the configuration of SELinux. Disable SELinux as a test and try again.

thepoch
Posts: 11
Joined: 2005/05/09 18:52:26

Re: Can't run phpMyAdmin

Post by thepoch » 2005/05/24 16:03:44

Where did you copy phpMyAdmin to and how? Anyway, this is most likely an SELinux issue. phpMyAdmin does work in CentOS 4.0 with SELinux enabled. I've set it up with cookie support.

Anyway, the trick is to login as root, then copy over the phpMyAdmin tarball to your preferred location (mine is /var/www/html). Then extract it there as root. This way SELinux permissions are the same as the directory. This is easier than having to change permissions by hand. I've encountered this problem before when I extract it using my account first, then copy it over to my www directory as root.

It's either that, or put SELinux in "permissive" mode, or disable it altogether. Running in permissive might get you tons of selinux warnings in /var/log, but at least you'll be able to learn it in the future. If you have absolutely no need or want for it, disable it to make things easier, avoiding issues like this phpMyAdmin thing.

Post Reply

Return to “CentOS 4 - Software Support”