SD card not partitioning (2 gig)

General support questions including new installations
Post Reply
KenHorse
Posts: 8
Joined: 2012/01/17 21:25:28

SD card not partitioning (2 gig)

Post by KenHorse » 2012/02/18 00:39:07

I run fdisk, create partitions (that list properly with p), exit using w yet nothing is written to the card as evidenced by fdisk -l.

No errors are reported and everything *appears* to go correctly but nothing is written to the card. And yes, I am sure the "lock" isn't on. Oh, and it is readable and writable on a Win 7 machine (after reformatting of course)

CentOS 4.8 final with 2.6.9-89.0.25.plus.c4 kernel

Oh and I'm using an IDE > sd card adapter and the system IS seeing it as /dev/hdc

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

SD card not partitioning (2 gig)

Post by pschaff » 2012/02/18 01:15:12

Any difference if you reboot after partitioning and before "fdisk -l"?

KenHorse
Posts: 8
Joined: 2012/01/17 21:25:28

Re: SD card not partitioning (2 gig)

Post by KenHorse » 2012/02/19 19:33:17

Nope.

On the other hand, I have an IDE > CF adapter and no problem at all with the CF partitioning, read or writing. But I want to use the sd card....

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: SD card not partitioning (2 gig)

Post by pschaff » 2012/02/19 19:43:36

Have you tried a different SD card? Some SDHC media that don't work out of the box can be fixed by the [url=http://panasonic.jp/support/global/cs/sd/download/sd_formatter.html]Panasoncic SDHC Formatter[/url] - YMMV - unfortunately a Windows-only tool. Might also be interesting to see if the adapter works on a later CentOS version. The driver may be an issue.

Post Reply

Return to “CentOS 4 - General Support”