USB external hard drive no longer detected in CentOS 4.4

General support questions including new installations
Post Reply
fuxin
Posts: 9
Joined: 2009/11/20 01:16:03

USB external hard drive no longer detected in CentOS 4.4

Post by fuxin » 2010/09/21 21:22:43

Hi all,

if I connect an external USB hard drive to my computer with CentOS 4.4 the hard drive doesn't show up in /media/ anymore. I use to make a backup every 1-2 months using this external drive and so far it always worked. The disk was available in /media/ and also under Places > Computer after pluging in the USB port. Now it doesn't show anything when I plug it in the USB port. I have also tried a USB pendrive with this computer which didn't work either. However, the keyboard is connected to the same USB port and it works. And the USB hard drive is detected on another Linux computers.

I was searching in the forum for similar cases but I didn't find any thread where it was reported that a USB drive was working first and then stopped. Therefore I would like to know what happened with this computer. Is there any particular log file that can provide this information or at least some hints? I remember the last date when everything was working and also I'm sure that since then no updates were installed.

Here is the information I got with getinfo.sh basic:

[code]== BEGIN uname -rmi ==
2.6.9-42.0.2.ELsmp x86_64 x86_64
== END uname -rmi ==
== BEGIN rpm -q centos-release ==
centos-release-4-4.2
== END rpm -q centos-release ==
== BEGIN getenforce ==
Disabled
== END getenforce ==[/code]

And the information from getinfo.sh disk can be found here: [url=http://pastebin.centos.org/34940]disk[/url]

Please let me know what I have to change in order to access the USB hard drive again!

Thanks in advance,
fuxin

User avatar
toracat
Forum Moderator
Posts: 7453
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

USB external hard drive no longer detected in CentOS 4.4

Post by toracat » 2010/09/22 01:29:49

Your CentOS version is quite old. I recommend you update it to the current CentOS 4.8.

Anyhow, try running [b]tail -f /var/log/messages[/b] and plug/unplug the hard drive. Do you see any output?

fuxin
Posts: 9
Joined: 2009/11/20 01:16:03

Re: USB external hard drive no longer detected in CentOS 4.4

Post by fuxin » 2010/09/22 19:31:08

Thanks toracat!

[quote]tail -f /var/log/messages[/quote] gives the following output while plugging and unplugging the USB of the hard drive:

Sep 22 14:31:11 mycomputer kernel: ehci_hcd 0000:00:1d.7: qh 00000100005140a0 (#0) state 1
Sep 22 14:31:11 mycomputer hald[4455]: Timed out waiting for hotplug event 1273. Rebasing to 1274
Sep 22 14:31:57 mycomputer hald[4455]: Timed out waiting for hotplug event 1279. Rebasing to 1273
Sep 22 14:31:59 mycomputer hald[4455]: Timed out waiting for hotplug event 1274. Rebasing to 1279

User avatar
toracat
Forum Moderator
Posts: 7453
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: USB external hard drive no longer detected in CentOS 4.4

Post by toracat » 2010/09/22 20:25:36

I still suggest you update your CentOS to the latest :-)

A post in this [url=http://www.linuxquestions.org/questions/linux-hardware-18/external-usb-hd-works-at-first-then-stops-after-creating-fs-568263/#post2906709]thread[/url] may be worth a try.
[quote]
I remember a similar problem in an old Fedora release. The issue there was that the system wasn't allowing enough time for the device to settle at boot. It seems that some external devices take a few extra seconds to spin up at boot, but the system skips them when they don't respond.

You can test this by recreating the problem, then:

sudo modprobe -r ehci_hcd
sudo modprobe ehci_hcd

If the drive comes up, then that's the issue.
[/quote]

Post Reply

Return to “CentOS 4 - General Support”