Page 1 of 2

startx won't start

Posted: 2010/07/19 11:34:38
by qwertyjjj
I'm trying to setup a linux server GUI that I can view with a Windows client.
I tried to start x on 1 but got the following errors.
Any ideas on what the problem could be?
I have started gdm as well.

[code]
[root ~]# startx -- :1
xauth: creating new authority file /root/.serverauth.397


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux serverxx-xxx-xxx-198.live-servers.net 2.6.18-164.11.1.el5 #1 SMP Wed Jan 20 07:39:04 EST 2010 i686
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Mon Jul 19 11:52:57 2010
(==) Using config file: "/etc/X11/xorg.conf"
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Multiple symbols for level 1/group 1 on key <I5F>
> Using XF86Sleep, ignoring XF86Standby
> Warning: Symbol map for key <I5F> redefined
> Using last definition for conflicting fields
Errors from xkbcomp are not fatal to the X server
localuser:root being added to access control list
No profile for user 'root' found
SESSION_MANAGER=local/serverxx-xxx-xxx-198.live-servers.net:/tmp/.ICE-unix/419
Initializing nautilus-open-terminal extension

** (eggcups:502): WARNING **: IPP request failed with status 1030

** (eggcups:502): WARNING **: IPP request failed with status 1030
** Message: Could not connect to power manager: Could not get owner of name 'org.gnome.PowerManager': no such name
Unable to open desktop file /usr/share/applications/redhat-email.desktop for panel launcher: No such file or directory
Unable to open desktop file /usr/share/applications/openoffice.org-1.9-writer.desktop for panel launcher: No such file or directory
Unable to open desktop file /usr/share/applications/openoffice.org-1.9-impress.desktop for panel launcher: No such file or directory
Unable to open desktop file /usr/share/applications/openoffice.org-1.9-calc.desktop for panel launcher: No such file or directory

** (nm-applet:545): WARNING **: No connections defined
Introspect error: The name edu.duke.linux.yum was not provided by any .service files
Traceback (most recent call last):
File "/usr/bin/puplet", line 467, in ?
main()
File "/usr/bin/puplet", line 464, in main
p.run()
File "/usr/bin/puplet", line 451, in run
self._refreshInfo()
File "/usr/bin/puplet", line 191, in _refreshInfo
if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'

[/code]

Do I have to kill startx as well?

ps- x

[code]
[root ~]# ps -x
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
PID TTY STAT TIME COMMAND
1 ? Ss 0:00 init [3]
2 ? S< 0:05 [migration/0]
3 ? SN 0:00 [ksoftirqd/0]
4 ? S< 0:00 [watchdog/0]
5 ? S< 0:03 [migration/1]
6 ? SN 0:00 [ksoftirqd/1]
7 ? S< 0:00 [watchdog/1]
8 ? S< 0:00 [events/0]
9 ? S< 0:00 [events/1]
10 ? S< 0:00 [khelper]
11 ? S< 0:00 [kthread]
15 ? S< 0:03 [kblockd/0]
16 ? S< 0:08 [kblockd/1]
17 ? S< 0:00 [kacpid]
158 ? S< 0:00 [cqueue/0]
159 ? S< 0:00 [cqueue/1]
162 ? S< 0:00 [khubd]
164 ? S< 0:00 [kseriod]
233 ? S< 3:56 [kswapd0]
234 ? S< 0:00 [aio/0]
235 ? S< 0:00 [aio/1]
393 ? S< 0:00 [kpsmoused]
424 ? S< 0:00 [ata/0]
425 ? S< 0:00 [ata/1]
426 ? S< 0:00 [ata_aux]
430 ? S< 0:00 [scsi_eh_0]
431 ? S< 0:00 [scsi_eh_1]
432 ? S< 0:00 [scsi_eh_2]
433 ? S< 0:00 [scsi_eh_3]
440 ? S< 0:00 [kstriped]
453 ? S< 1:47 [kjournald]
477 ? S< 0:03 [kauditd]
508 ? S<s 0:00 /sbin/udevd -d
532 ? S 0:00 /usr/libexec/gam_server
610 pts/0 S 0:00 /bin/sh /usr/bin/startx -- :1
627 pts/0 S 0:00 xinit /etc/X11/xinit/xinitrc -- /usr/bin/X :1 -auth /root/.serverauth.610
628 tty9 S<s+ 0:00 /usr/bin/X :1 -auth /root/.serverauth.610
645 pts/0 T 0:00 /usr/bin/gnome-session
670 ? Ss 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
673 pts/0 T 0:00 /usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
674 ? Ss 0:00 /bin/dbus-daemon --fork --print-pid 4 --print-address 6 --session
680 pts/0 T 0:00 /usr/libexec/gconfd-2 5
683 pts/0 T 0:00 /usr/bin/gnome-keyring-daemon
685 ? Sl 0:00 /usr/libexec/gnome-settings-daemon
705 ? Ss 0:00 metacity --sm-client-id=default1
709 ? Ss 0:00 gnome-panel --sm-client-id default2
711 ? Ss 0:00 nautilus --no-default-window --sm-client-id default3
716 ? S 0:00 /usr/libexec/gnome-vfs-daemon
730 ? S 0:00 /usr/libexec/wnck-applet --oaf-activate-iid=OAFIID:GNOME_Wncklet_Factory --oaf-ior-fd=19
732 ? S 0:00 /usr/libexec/trashapplet --oaf-activate-iid=OAFIID:GNOME_Panel_TrashApplet_Factory --oaf-ior-fd=25
735 ? Ss 0:00 eggcups --sm-client-id default4
739 ? Sl 0:00 /usr/libexec/mixer_applet2 --oaf-activate-iid=OAFIID:GNOME_MixerApplet_Factory --oaf-ior-fd=20
745 ? Ss 0:00 bt-applet --sm-disable
758 ? Sl 0:00 ./escd --key_Inserted="/usr/bin/esc" --on_Signal="/usr/bin/esc"
760 ? Ss 0:00 nm-applet --sm-disable
764 ? S 0:00 /usr/libexec/notification-area-applet --oaf-activate-iid=OAFIID:GNOME_NotificationAreaApplet_Factory --oaf-ior-fd=21
766 ? S 0:00 /usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory --oaf-ior-fd=28
770 ? Ss 0:00 pam-panel-icon --sm-client-id default0
774 ? Ss 0:00 gnome-power-manager
775 ? S 0:00 /sbin/pam_timestamp_check -d root
777 ? S 0:00 /usr/libexec/mapping-daemon
782 ? S 0:00 gnome-screensaver
802 ? S 0:00 /usr/sbin/gdm-binary
811 tty8 Ss+ 0:00 /usr/bin/Xorg :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt8
857 pts/0 R+ 0:00 ps -x
1242 ? S< 0:00 [hd-audio0]
1604 ? S< 0:00 [kmpathd/0]
1605 ? S< 0:00 [kmpathd/1]
1606 ? S< 0:00 [kmpath_handlerd]
1633 ? S< 1:21 [kjournald]
1635 ? S< 0:00 [kjournald]
1850 ? S< 0:00 [kondemand/0]
1851 ? S< 0:00 [kondemand/1]
2349 ? S< 0:00 [rpciod/0]
2350 ? S< 0:00 [rpciod/1]
2364 ? S 0:00 /usr/sbin/courierlogger -pid=/var/spool/authdaemon/pid -start /usr/libexec/courier-authlib/authdaemond
2365 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2411 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2412 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2413 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2414 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2415 ? S 0:00 /usr/libexec/courier-authlib/authdaemond
2454 ? Ss 0:00 /usr/sbin/hcid
2488 ? S< 0:00 [krfcommd]
2543 ? Ss 0:00 /usr/sbin/acpid
2563 ? Ss 0:00 /usr/bin/hidd --server
2854 ? Ss 0:00 /usr/sbin/httpd-matrixsa
2867 ? Ss 0:07 crond
2944 ? S 0:00 hald-runner
3104 tty2 Ss+ 0:00 /sbin/mingetty tty2
3105 tty3 Ss+ 0:00 /sbin/mingetty tty3
3106 tty4 Ss+ 0:00 /sbin/mingetty tty4
3110 tty5 Ss+ 0:00 /sbin/mingetty tty5
3122 tty6 Ss+ 0:00 /sbin/mingetty tty6
3509 ? Ss 0:14 /usr/lib/postfix/master
4998 ? S 0:01 [pdflush]
7191 ? Ss 0:06 syslogd -m 0
7194 ? Ss 0:00 klogd -x
7518 ? S 0:11 /usr/bin/oprofiled --session-dir=/var/lib/oprofile --separate-lib=1 --separate-kernel=1 --separate-thread=0 --separate-cpu=0 --events=CPU_CLK_UNHALTED
8684 ? Ss 0:00 /usr/sbin/atd
8722 ? Ss 0:00 rpc.idmapd
8807 ? Ssl 0:00 automount
8947 ? S<sl 0:19 auditd
8949 ? S<sl 0:09 /sbin/audispd
9069 ? Ss 0:00 squid -D
9325 ? Sl 0:17 python MatrixSALaunch.py ThreadedAppServer
10389 ? S 0:02 [pdflush]
18257 ? Ssl 0:00 pcscd
20460 ? Ss 0:00 cupsd
22202 ? Ss 0:00 /usr/sbin/gdm-binary
22205 ? Sl 0:00 /usr/libexec/gdm-rh-security-token-helper
22385 ? S 0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
22764 ? Ssl 0:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=16
26297 ? Ss 0:00 (ncsa_auth) /etc/squid/xxxxx
26298 ? Ss 0:00 (ncsa_auth) /etc/squid/xxxxx
26299 ? Ss 0:00 (ncsa_auth) /etc/squid/xxxxx
26300 ? Ss 0:00 (ncsa_auth) /etc/squid/xxxxx
26301 ? Ss 0:00 (ncsa_auth) /etc/squid/xxxxx
30911 ? Ss 0:00 /usr/sbin/sshd
30936 ? S 0:00 /bin/sh /usr/bin/mysqld_safe --datadir=/var/lib/mysql --socket=/var/lib/mysql/mysql.sock --log-error=/var/log/mysqld.log --pid-file=/var/run/mysqld/my
31493 tty1 Ss+ 0:00 /sbin/mingetty tty1
31521 ? S< 0:01 [reiserfs/0]
31522 ? S< 0:01 [reiserfs/1]
32732 ? Ss 0:00 sshd: xxxxx [priv]
32752 pts/0 S 0:00 su -
32753 pts/0 S 0:00 -bash
[/code]

startx won't start

Posted: 2010/07/20 00:47:29
by pschaff
You need to learn some basics of displaying on a [url=http://www.google.com/search?q=remote+X+server&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a]remote X server[/url] - in this case on Windows. Alternatively, perhaps you might want to have a look at http://wiki.centos.org/HowTos/FreeNX and/or http://wiki.centos.org/HowTos/VNC-Server .

Re: startx won't start

Posted: 2010/07/20 11:15:03
by qwertyjjj
Hi
Thanks for the links, I'm reading through them but I searched for this specific error on Google and couldn't find a solution.
The above error is on Linux not Windows and I need to get the x server started first before I can use VNC or anything to connect remotely don't I?

Re: startx won't start

Posted: 2010/07/20 13:37:40
by pschaff
It seems backwards, but an [url=http://en.wikipedia.org/wiki/X_Window_System]X server[/url] runs on the system on which the display is done - in your case Windows. The X client applications run on the CentOS system (server in the more conventional sense) with display on the X server. No, you do not [i]need[/i] to run an X server on the CentOS system, although you might want to if sitting at the CentOS console, rather than your remote system.

Re: startx won't start

Posted: 2010/07/20 14:04:27
by qwertyjjj
That's strange because all the documentation seems to say:
yum groupinstall "X Window System" "GNOME Desktop Environment"

So, I have gdm started - is that all I need?
I'm worried I have some unecessary x processes running on the server now - should I just search for gdm processes and leave them running or is xdm better (as mentioned in the links above)?
Also, can I use x to view an iknstralled program or does it have to be an xprogram? The docs only mention xclock, etc.
For exmaple, could I install Skype on the server and then view it via X on windows?
I have xming installed on the Windows client at present.

Really...I just want a GUI on the server that I can connect to remotely.

It does not seem to recognise my password when I login to uservnc even after creating the user

[root ~]# useradd uservnc
Creating mailbox file: File exists
useradd: warning: the home directory already exists.
Not copying any file from skel directory into it.
[root ~]# passwd uservnc
Changing password for user usertvnc.
New UNIX password:
Retype new UNIX password:
passwd: all authentication tokens updated successfully.

Re: startx won't start

Posted: 2010/07/20 14:40:28
by pschaff
It is not obvious what your are doing wrong from the information provided, but "uservnc" will not exist by default so something was done to create it before what you showed. All I can think to add is follow the VNC Wiki article if going with VNC.

Re: startx won't start

Posted: 2010/07/20 15:00:28
by qwertyjjj
Okay...I have got it running over VNC logged in as a NON root user.
However, I then logged out of the system.
When I reconnected through VNC viewer, it no longer shows me the "Computer" Icon or System or anything else, just a bash script. ANy ideas on how to get it to redisplay?

Edit: got it: gnome-session though I received some erros on doing that

Re: startx won't start

Posted: 2010/07/20 15:46:04
by qwertyjjj
I have managed to get a Windows program running on the server through this and vieing it with VNC.
However, when I disconnect the VNC, it logs me off and I assume stops the program running at the same time.
ANy ideas on how I can keep it running?

Also, I assume I needto run VNC through SSH for security?

Re: startx won't start

Posted: 2010/07/20 16:33:30
by pschaff
You should be able to disconnect and [url=http://www.google.com/search?q=VNC+session+reconnect&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&safe=active]reconnect[/url] to a VNC session. The required security really depends on your environment. On a trusted private subnet it may not be required, but across the Internet an ssh tunnel would be a good idea.

Re: startx won't start

Posted: 2010/07/20 16:44:33
by qwertyjjj
I tried to change the resolution and when I reconnected, it doesn't show me the menu, also when I minimise the xterm, I can't get it back as I can no longer see the task bar across the bottom.
I changed the res back to the original, but it still doesn't appear. Any ideas?
Reason I asked about the program is that when I close down the VNC and reconnect, none of the windows of the application I was running are there anymore so it must hev been closed?