Yum update fails openSSL dependency HELL!

General support questions including new installations
Post Reply
Bodie
Posts: 5
Joined: 2005/12/18 12:11:56

Yum update fails openSSL dependency HELL!

Post by Bodie » 2010/07/01 14:23:47

Hi Guys,
Running a real stable CentOS 4.8 Samba PDC.
I have been trying to do a yum update with the following error returned.
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package httpd.x86_64 0:2.0.52-41.ent.7.centos4 set to be updated
--> Running transaction check
--> Processing Dependency: httpd = 2.0.52-41.ent.6.centos4 for package: httpd-suexec
--> Processing Dependency: httpd = 2.0.52-41.ent.6.centos4 for package: mod_ssl
--> Finished Dependency Resolution
Error: Missing Dependency: httpd = 2.0.52-41.ent.6.centos4 is needed by package httpd-suexec
Error: Missing Dependency: httpd = 2.0.52-41.ent.6.centos4 is needed by package mod_ssl

This is a production server but as it is now YUM is dysfunctional.
[b][size=96][color=006600][font=Georgia]Any suggestions?[/font][/color][/size][/b]
Thanks!

pschaff
Retired Moderator
Posts: 18276
Joined: 2006/12/13 20:15:34
Location: Tidewater, Virginia, North America
Contact:

Re: Yum update fails openSSL dependency HELL!

Post by pschaff » 2010/07/01 15:54:40

Please read [url=http://www.centos.org/modules/newbb/viewtopic.php?topic_id=25128&forum=47]How to provide information about your system[/url] and provide the output from [b]./getinfo.sh package[/b]. It would also be useful to provide the entire output from "yum update".

Bodie
Posts: 5
Joined: 2005/12/18 12:11:56

Re: Yum update fails openSSL dependency HELL!

Post by Bodie » 2010/07/06 13:48:47

Ok I'll try to submit this after I've had a chance to copy the script and submit the results,Thanks!

Bodie
Posts: 5
Joined: 2005/12/18 12:11:56

Re: Yum update fails openSSL dependency HELL!

Post by Bodie » 2010/07/07 13:26:34

The results of get info are posted here

[[url=http://pastebin.centos.org/33680]Get Info Output[/url]


The yum output is below.....any ideas guys?
Thanks!


Loading "priorities" plugin
Setting up Update Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
centosplus 100% |=========================| 951 B 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
201 packages excluded due to repository priority protections
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package httpd.x86_64 0:2.0.52-41.ent.7.centos4 set to be updated
---> Package perl.x86_64 3:5.8.5-53.el4 set to be updated
---> Package kernel-smp.x86_64 0:2.6.9-89.0.25.EL set to be installed
---> Package kdebase.i386 6:3.3.1-13.el4_8.1.centos set to be updated
---> Package iptables.x86_64 0:1.2.11-3.3.el4_8 set to be updated
---> Package postgresql-libs.i386 0:7.4.29-1.el4_8.1 set to be updated
---> Package krb5-libs.i386 0:1.3.4-62.el4_8.2 set to be updated
---> Package tzdata.noarch 0:2010i-1.el4 set to be updated
---> Package device-mapper-multipath.x86_64 0:0.4.5-35.el4_8.3 set to be updated
---> Package kernel-doc.noarch 0:2.6.9-89.0.25.EL set to be updated
---> Package kdebase.x86_64 6:3.3.1-13.el4_8.1.centos set to be updated
--> Running transaction check
--> Processing Dependency: httpd = 2.0.52-41.ent.6.centos4 for package: httpd-suexec
--> Processing Dependency: httpd = 2.0.52-41.ent.6.centos4 for package: mod_ssl
--> Finished Dependency Resolution
Error: Missing Dependency: httpd = 2.0.52-41.ent.6.centos4 is needed by package httpd-suexec
Error: Missing Dependency: httpd = 2.0.52-41.ent.6.centos4 is needed by package mod_ssl

Post Reply

Return to “CentOS 4 - General Support”